Posts by atrujillo

This forum was archived to /woltlab and is now in read-only mode.

    Now a fix that, but i have that information in icinga2.log

    Code
    1. [2017-11-23 10:17:56 -0500] information/ApiListener: Reconnecting to endpoint 'gestion0.upr.edu.cu' via host '10.2.1.3' and port '5665'
    2. [2017-11-23 10:17:56 -0500] critical/TcpSocket: Invalid socket: Connection refused
    3. [2017-11-23 10:17:56 -0500] critical/ApiListener: Cannot connect to host '10.2.1.3' on port '5665'
    4. [2017-11-23 10:17:56 -0500] information/ApiListener: Finished reconnecting to endpoint 'gestion1.upr.edu.cu' via host '10.2.1.3' and port '5665'

    Hi,


    did you create an endpoint object inside your zone.conf on your Icinga master?

    https://www.icinga.com/docs/ic…ted-monitoring/#endpoints

    did you refer to that ?

    Hello a while ago I have a working server icinga2 using icinga2 agent from version 2.8 all change drastically, install a new server to test and understand how CA proxy works and still can not solve the problem I follow the instructions that refer here : https://www.icinga.com/2017/11/13/how-to-icinga-2-ca-proxy/ using On-Demand CSR Signing

    Code
    1. [root@icinga2 ~]# icinga2 ca list
    2. Fingerprint | Timestamp | Signed | Subject
    3. -----------------------------------------------------------------|--------------------------|--------|--------
    4. 79b36a3d400ffaa784319c6ee4045e5fffe1b9174de37aab5e477f00d58037be | Nov 22 20:33:49 2017 GMT | * | CN = gestion1.upr.edu.cu
    5. bf312ffb39e17812bfb6bd11b67fda28689bf2eb145cf00fe839c31c137bbf8a | Nov 20 21:22:39 2017 GMT | * | CN = gestion1.upr.edu.cu
    6. [root@icinga2 ~]#


    Code
    1. [root@icinga2 ~]# icinga2 ca sign 79b36a3d400ffaa784319c6ee4045e5fffe1b9174de37aab5e477f00d58037be
    2. information/cli: Signed certificate for 'CN = gestion1.upr.edu.cu'.

    Log

    Code
    1. [2017-11-22 15:38:05 -0500] warning/JsonRpcConnection: API client disconnected for identity 'gestion1.upr.edu.cu'
    2. [2017-11-22 15:39:05 -0500] information/ApiListener: New client connection for identity 'gestion1.upr.edu.cu' from [10.2.1.4]:51758 (no Endpoint object found for identity)

    Any idea, some body can help me

    Hello there.
    I have got a icinga2 server when I try add a satelite server whith remote monitoring.
    install icinga node wizard
    in some server I have got this error.
    root@storage0:~# icinga2 node wizard[2016-11-30 11:28:27 -0500] information/icinga-app: Icinga application loader (version: r2.1.1-1)[2016-11-30 11:28:27 -0500] information/icinga-app: Loading application type: icinga/IcingaApplication[2016-11-30 11:28:27 -0500] information/Utility: Loading library 'libicinga.so'[2016-11-30 11:28:27 -0500] information/ConfigCompiler: Adding include search dir: /usr/share/icinga2/include[2016-11-30 11:28:27 -0500] critical/icinga-app: Another instance of Icinga already running with PID 2188root@storage0:~#
    I have got a idea with this errors, the operating system of its server they are Debian but that server are OpenMediaVault or Proxmox 4 System too, and this plataform provide a graphics, nagios-plugins and icinga2 may be used for this graphics.


    Someone people can help me, please?

    Hello there, I'm have a problem with icinga2 node wizard in host, when I install icinga in host node, and put this icinga2 node wizard, the host gives this messages:


    TeX
    1. [2016-09-03 17:45:57 -0400] information/icinga-app: Icinga application loader (v ersion: r2.1.1-1)
    2. [2016-09-03 17:45:57 -0400] information/icinga-app: Loading application type: ic inga/IcingaApplication
    3. [2016-09-03 17:45:57 -0400] information/Utility: Loading library 'libicinga.so'
    4. [2016-09-03 17:45:57 -0400] information/ConfigCompiler: Adding include search di r: /usr/share/icinga2/include
    5. [2016-09-03 17:45:57 -0400] critical/icinga-app: Another instance of Icinga alre ady running with PID 19821

    this critical message does not allow me continue wtich the wizard nodo installation.
    Any idea?
    thanks

    http://docs.pnp4nagios.org/pnp…grade_scenario_using_npcd


    Please check Point 5,6,and 8


    Did you check your apache config and logs?

    Step 5 and 6 had done, the 8, the directory is not empty, because copying the previous version
    besides when I http://servernagios/pnp4nagios/
    i get this :




    PNP4Nagios Environment Tests



    The following options are determined by "configure". If any of the tests have failed, consult the documentation for more information on how to correct the problem.







    PNP4Nagios Version
    pnp4nagios-0.6.2



    Prefix
    /usr/local/pnp4nagios



    RRD Storage
    /usr/local/pnp4nagios/var/perfdata is readable.



    RRDtool Binary
    /usr/bin/rrdtool



    PHP GD extension
    Pass



    PHP function proc_open()
    Pass



    PHP zlib extension
    Pass



    PHP session extension
    Pass


    PHP magic_quotes_gpc
    PHP magic_quotes_gpc is deprecated


    Apache Rewrite Module
    Pass