Posts by olix2000

This forum was archived to /woltlab and is now in read-only mode.

    Hallo,

    im Rahmen einiger Aktualisierungen habe ich Check_MK RAW Edition 1.2.8p20 mit NagVis 1.9b10 auf ein neues Ubuntu 16.0.4 installiert und eine Sicherung über WATO zurückgespielt. Alles sieht prima aus und funktioniert, bis auf den NagVis-Teil.

    Der Fehler hier ist, dass alle Icons und Gadgets übereinander ganz oben links angesiedelt und die Menüs (Kartenkonfiguration etc.) nur teilweise sichtbar sind. Es scheint, als würden die Menus unter das Hintergrundbild geschoben werden.

    Wenn ich eine neue Karte erstelle, passiert hier genau das gleiche. Die Karten-Konfigurationen sind alle korrekt.


    Hat jemand eine Idee, was hier schief läuft?


    Viele Grüße


    Oliver

    Habe jetzt alles aktualisiert auf 1.2.8p20 und sehe auch, dass der McAfee enthalten ist. Allerdings wird der Check bei der Inventarisierung nicht für Clients mit installiertem McAfee angezeigt. Der Agent auf den Windows-Server ist natürlich auch aktuell.

    Wonach genau sucht denn der Agent?

    Hallo,


    ich schließe mich hier noch einmal an, weil ich dieses Update (omd 1.30 auf console-labs 2.20) gerade vollzogen habe. Sieht auch soweit alles gut aus, aber die check_mk-Version ist nach wie vor 1.2.6p12. Fließen hierfür keine Updates mehr in die Distributionen? Oder kann man jetzt die CRE separat installieren?


    Viele Grüße


    Oliver

    Hallo,


    ich setze check_mk 1.2.6p12 (OMD-Distribution) ein und würde damit gerne die Aktualität der Virenpattern (McAfee) überprüfen. Unter https://mathias-kettner.de/che…eck_mcafee_av_client.html habe ich gesehen, dass der Check eigentlich Teil von check_mk sein soll, kann ihn aber nirgends finden. Ich hätte ihn jetzt mal bei den manuellen Checks unter "Age of last Virus Update" vermutet, da kann ich aber leider nur Symantec auswählen.

    Kann mir jemand sagen, wo ich McAfee aktivieren kann?


    Viele Grüße


    Oliver

    OK, ich sehe es ist machbar :)


    Auf den Berichtsplaner in Wato bin ich auch schon gestoßen, allerdings nur auf der Webseite. Bei mir taucht der Punkt Reporting gar nicht auf.
    Ab welcher Version ist der denn enthalten? Oder muss das auch noch aktiviert werden wie die Event-Console?

    Vielen Dank für die schnelle Antwort.
    Für ein Skript habe ich hier schon den ein oder anderen Ansatz gelesen, hatte aber gehofft das mit dem Bericht-Modul von check_mk erledigen zu können. Das kann ich allerdings in der momentanen Version auch nicht sehen.


    Kann ich denn Thruk parallel zu check_mk aufrufen und dort nur die Berichtsfunktion nutzen ohne da auch noch großartig etwas konfigurieren zu müssen?


    Ich nutze Nagios als Core.

    Hallo zusammen,


    vielleicht sehe ich aufgrund der vielen Möglichkeiten den Wald vor lauter Bäumen nicht, aber ich würde gerne jeden Tag zu einer bestimmten Uhrzeit den aktuellen Status der überwachten Umgebung per Mail gesendet bekommen. Ich nutze bislang dafür das Skript nagios-reporter-131.pl welches morgens früh eine Übersicht schickt, was in der Nacht passiert ist.
    Mich interessiert aber nur, welche Probleme aktuell auftreten.


    Ich nutze die OMD-Version 1.30 mit der darin enthaltenen check_mk-Version


    Ich bin für jede Idee dankbar.


    Viele Grüße


    Oliver

    Hallo Mathias,


    danke für die Antwort. Mit den Hosttags habe ich auch schon rumprobiert und sofern die Hostgruppen schon existieren werden die Hosts auch korrekt zugeordnet (define_hostgroups = True
    funktioniert leider bei mir aus welchen Gründen auch immer nicht), aber trotzdem werden alle Dienste pro Host jeweils einmal erstellt und die Konfigdateien werden somit recht unübersichtlich. Oder gibt es mit den Tags auch die Möglichkeit Dienste manuell einer Hostgruppe zuzuordnen ? Das wäre dann ähnlich wie die Option service_contactgroups wo die Dienste den Kontaktgruppen zugeordnet werden.


    Oli

    Hallo,


    ich habe mir mal check_mk besorgt und ein wenig damit rumprobiert. Sieht echt gut aus und nimmt einem bestimmt auch eine Menge Arbeit ab. Was mir nur auffällt ist, dass alle Dienste für jeden Host einzeln in die Konfigdateien eingetragen werden. Gibt es hier eine Möglichkeit, gewisse Dienste nur den Hostgruppen zuzuordnen ? Das würde alles etwas übersichtlicher machen.
    Beispiel:


    im Moment sieht es so aus:
    Host: WindowsServer_1
    Dienst: Log_System


    Host: WindowsServer_2
    Dienst: Log_System


    Übersichtlicher wäre sicherlich:
    Hostgruppe: WindowsServer
    Dienst: Log_System


    Da in der Konfigurationsdatei ja schon alle Hosts und ihre Hostgruppen definiert werden können, müsste es doch eigentlich da eine Möglichkeit geben, oder?


    Viele Grüße


    Oli

    Hallo,


    vielleicht kann mir jemand bei dem folgenden Problem helfen:
    Ich habe blosxom4nagios installiert und es werden auch Nachrichten auf der Webseite angezeigt, jedoch ohne vollständige Formatierung. Genaueres sieht man im Screenshot.
    Bei der Installation habe ich mich weitestgehend an die Anleitung gehalten. Lediglich das Installationsverzeichnis habe ich nach /usr/local/nagios/share/blosxom geändert. DIe Pfade habe ich in den Dateien blosxom4nagios.conf und blosxom.conf angepasst. Bei den "Rewritecond"-Einträgen bin ich mir unsicher ob hier der Pfad des Webservers (nagios/blosxom) oder der Pfad im Dateisystem (nagios/share/blosxom/) gewählt werden muss.
    Hat jemand eine Idee, wo es dran liegen könnte?


    Viele Grüße


    Oli

    Hallo zusammen,


    bis jetzt habe ich mich munter durch alle möglichen Nagios-Plugins etc. durchgehangelt und bin auch mehr als zufrieden mit dem Ergebnis. Probleme macht mir nur der Einsatz von snmptt.
    Das es Probleme beim init-Script mit Ubuntu gibt, habe ich bereits gelesen, kann ich aber mit leben.
    Wenn ich snmptt im deamon-Modus laufen lasse, startet zwar alles sauber ich bekomme aber keine Einträge in meine Datenbank.
    Snmptt im standalone-Modus funktioniert nur, wenn ich net_snmp_perl_enable = 0 einstelle, bei 1 kommt beim Eintreffen eines Traps die Fehlermeldung: Undefined Subroutine &SNMP::initMib();
    Ich habe schon etliche Pakete installiert, die mit snmp und perl zu tuen haben, u.a.
    libsnmp-base 5.4.1~dfsg-7.1ubuntu6.1 SNMP (Simple Network Management Protocol) MIBs and documentation
    ii libsnmp-dev 5.4.1~dfsg-7.1ubuntu6.1 SNMP (Simple Network Management Protocol) development files
    ii libsnmp-info-perl 1.04-4 Object Oriented Perl5 Interface to Network devices and MIBs through SNMP
    ii libsnmp-mib-compiler-perl 0.06-2 a MIB Compiler supporting SMIv1 and SMIv2
    ii libsnmp-multi-perl 2.1-4 Perform SNMP operations on multiple hosts simultaneously
    ii libsnmp-perl 5.4.1~dfsg-7.1ubuntu6.1 SNMP (Simple Network Management Protocol) Perl5 support
    ii libsnmp-session-perl 1.12-1 Perl support for accessing SNMP-aware devices
    ii libsnmp15


    trotzdem kommt immer wieder dieser Fehler.


    In welchem Paket von ubuntu steckt denn diese Subroutine drin?????


    Viele Grüße


    Oli