Posts by jonask

This forum was archived to /woltlab and is now in read-only mode.

    Ich prüfe damit ob meine Win DCs noch DNS machen so wie sie es sollen.


    check_dig tut es so wie es sein sollte, werde nun meine commands umstellen.


    Ist ja eigentl. kein Pluginproblem, aber sollte evtl. in der Doku/Hilfe zu dem Plugin beschrieben werden, versuch das mal abzusetzen oder habt ihr einen direkten Draht.



    Vielen Dank für die schnellen Antworten.

    Hallo,


    habe auf einem RHEL 5 folgenden Effekt:


    # ./check_dns -H einHost -s einDNSServer


    erhalte dann


    DNS OK: 0,026 seconds response time. einHost returns 10.x.x.1|time=0,025999s;;;0,000000


    soweit OK.


    Ändere ich die Option -s auf einen nicht exisitierenden Server gibt es einen Fehler, soweit OK.


    Ändere ich die Option -s auf einen exisitierenden nicht DNSServer oder einen wo der DNS Dienst steht, gibt es keinen Fehler=schlecht.


    Das liegt am Verhalten von nslookup auf dem RHEL 5:


    #nslookup einHost einDNSServer


    Server: einDNSServer
    Address: 10.X.X.1#53


    Name: einHost


    Address: 10.Y.Y.1



    #nslookup einHost einServerDNS-AUS


    Server: 10.X.X.1 (aus der resolv.conf)
    Address: 10.X.X.1#53


    Name: einHost


    Address: 10.Y.Y.1



    Nslookup ignoriert also einfach, wenn der vorgegbene Server kein DNS spricht und nimmt dann den aus der resolv.conf.


    Man sieht das nur da bei "Server:" dann eine IP-Adresse steht.


    Auf meinen älteren Fedora Systemen, wird ein Fehler ausgegeben nur auf dem RHEL 5 nicht.


    Da ich aber meine DNS Server auf Funktion prüfen will brauche ich ja die -s Funktion: $USER1$/check_dns -H $ARG1$ -a $ARG2$ -s $HOSTADDRESS$


    und da mein Dell Server mit RHEL 5 inc. Support kam, will ich schon dabei bleiben.



    Hat das schon mal jemand bemerkt? Man denkt alle DNS Serverlaufen, bekommt aber nur Antwort von einem einzigen....



    Kann ich das irgendwie anders lösen?



    Gruß Jonas