Posts by enjl

This forum was archived to /woltlab and is now in read-only mode.

    Greetings,


    I'm new to icinga and I want to configure my system so that I get to a specific problem only once a notification.

    Currently I get an alert every two hours because of the same problem. I wanted to solve the problem by setting

    the attribute "interval" to 0, but it did nothing.


    Here are my Notification-Templates where I set the attribute "interval" to 0:

    Code
    1. template Notification "mail-host-notification" {  command = "mail-host-notification"
    2.   states = [ Up, Down ]  types = [ Problem, Acknowledgement, Recovery, Custom,            FlappingStart, FlappingEnd,            DowntimeStart, DowntimeEnd, DowntimeRemoved ]
    3.   period = "24x7"  interval = 0}
    4. template Notification "mail-service-notification" {  command = "mail-service-notification"
    5.   states = [ OK, Warning, Critical, Unknown ]  types = [ Problem, Acknowledgement, Recovery, Custom,            FlappingStart, FlappingEnd,            DowntimeStart, DowntimeEnd, DowntimeRemoved ]
    6.   period = "24x7"  interval = 0}


    Has someone an idea how I can solve this problem?

    Thank you for your help sru!


    Have I understood that correctly? If I remove the variables "vars.wartung_downtime = "" " in the templates and modify my ScheduledDowntime with"assign where service.name", this downtime will be applied to any service? And will it be displayed in the web interface icingaweb2? (I currently have problems with my server and cannot test it now)

    Greetings,


    I have set up a ScheduledDowntime for my Icinga2 system to avoid notifications during maintenance work at night, but I'm afraid I've done something wrong. The problem is I cannot see my Downtime in the webinterface Icingaweb2. When I look at the overview for Downtimes there is only the default ScheduledDowntime displayed. I added an image with the overview to the Attachments.


    My ScheduledDowntime:


    To assign every Host and Service this ScheduledDowntime, I created the Custom Attribute vars.wartung_downtime:


    System informations:
    icinga2: r2.6.0-1?
    icingaweb2: 2.3.4?
    ubuntu: Ubuntu 14.04.5 LTS


    I would be happy for any kind of help,

    lisa

    Thank you for your replies!


    Here are the Notification Templates:


    "mail-host-notification"

    Code
    1. template Notification "mail-host-notification" {
    2.     command = "mail-host-notification"
    3.   states = [ Up, Down ]
    4.     types = [ Problem, Acknowledgement, Recovery, Custom,
    5.             FlappingStart, FlappingEnd, DowntimeRemoved ]
    6.   period = "24x7"
    7.     interval = 0
    8. }

    "mail-service-notificatin"

    Code
    1. template Notification "mail-service-notification" {
    2.     command = "mail-service-notification"
    3.   states = [ OK, Warning, Critical, Unknown ]
    4.     types = [ Problem, Acknowledgement, Recovery, Custom,
    5.             FlappingStart, FlappingEnd, DowntimeRemoved ]
    6.   period = "24x7"
    7.     interval = 0
    8. }

    As I already mentioned, I removed from types DowntimeStart and DowntimeEnd. I also set interval=0 because I only want be

    notified once when a problem occurs.




    I will also try to update my icinga2-system from r2.5.4-1 to 2.6.0

    Greetings,



    I am new to Icinga2 and I can't find a solution for my problem.



    In my school-project I have to improve the Icinga2 System. One of my task
    is to setup Downtimes because of maintenance work at night. The admins and
    my teacher are always getting notifications during that time. So I created
    a new ScheduledDowntime in the downtimes.conf. But now I have the problem
    that Icinga2 is always sending Downtimestart und Downtimeend-Notifications
    which is much worse.



    donwtimes.conf



    To assing every host to this downtime I created a new variable wartung_downtime
    for the templates "generic-host" and "generic-service" in template.conf.



    template.conf



    I also tried to edit the templates "mail-host-notification" and
    "mail-service-notification". I deleted from types: DowntimeStart, DowntimeEnd.
    But this did'nt solve the problem.



    System informations:
    icinga2: r2.5.4-1
    ubuntu: Ubuntu 14.04.5 LTS



    I would be very grateful for any help,
    lisa