Icinga Backend not running

This forum was archived to /woltlab and is now in read-only mode. Please register a new account on our new community platform.

You can create a thread on the new site and link to an archived thread. This archive is available as knowledge base, safe and secured.

More details here.
  • Hello Everybody,


    first of all merry christmas to you!


    After a lot of debugging, reading logfiles and research I am now reaching out to you.


    Some days ago I installed Icinga2 and IcingaWeb2 on my CentOS7 Server.

    Where Icinga2 has been installed from source.


    While checking out the IcingaWeb2 I recognised the system telling me, that the Icinga backend is not running.

    What I don´t get is, that if I run the service via "icinga2 daemon", the communication between IcingaWeb2 and Icinga2 works perfectly fine and the warning is gone within seconds.


    After killing the process, it takes some time and the warning comes back, as expected.

    Starting Icinga2 via systemd unit-file doens´solve this issue.

    By tailing the postgresql logs, I can see, that there is no connection to the icinga datbase when running via systemd.


    I even tried strace, but actually I don´t get anything out these lines.


    Hope you guys can help me out, since I am running out of ideas.


    Let me give you some info about my config and setup:


    Host system: CentOS Linux release 7.4.1708 (Core)


    Icinga2 installed from source, completely into /opt/icinga2:


    Code: Icinga Cmake
    1. su icinga -s /bin/bash -c "cd /opt/icingaBuild/; mkdir build; cd build; cmake .. -DCMAKE_INSTALL_PREFIX='/opt/icinga2' -DICINGA2_USER='icinga' -DICINGA2_GROUP='icinga' -DICINGA2_COMMAND_GROUP='icingacmd' -DICINGA2_WITH_MYSQL=OFF -DUSE_SYSTEMD=ON -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=ON; make"


    Icinga2 --version: The Icinga 2 network monitoring daemon (version: v2.8.0-169-geea8e4e)

    Icinga2 enabled features: checker command ido-pgsql livestatus mainlog notification perfdata statusdata



    IcingaWeb2 Version: 2.5.0

    IcingaWeb2 Modules: Monitoring, Doc


    Attached find some of the config files, If you need anything else I´ll gladly help you to help me :D

  • Btw, gerne auch auf deutsch.


    Dachte nur so erwische ich vielleicht eher jemanden der mir helfen kann.

  • Hallo sru,


    danke für die Rückmeldung.

    Selinux ist natürlich schon aus, stand irgendwo in dem tutorial an dem ich mich langgehangelt habe.

    Da ich nicht aus einem Repo installiert habe kommt natürlich auch keine Seinux-Regel mit, so arbeite ich aktuell mit folgender Config:



    Bezüglich meines Problems habe ich alle Foreneinträge bereits durchwühlt.

    Also alles was als Return mit dem Suchstring ~ "Icinga Backend not running" kommt.


    Das Interessante ist ja, dass es im foreground läuft, die ido-pgsql aber via background daemon aussteigt.


    Hier noch ein Auszug aus der Shell:


    Code: /opt/icinga2/sbin/icinga2 daemon -x debug -X -c /opt/icinga2/etc/icinga2/icinga2.conf -d -e /opt/icinga2/var/log/icinga2/icinga2.log
    1. [2017-12-26 18:36:55 +0100] debug/LegacyTimePeriod: ParseTimeRange: 'monday' => 1514761200 -> 1514847600, stride: 1
    2. [2017-12-26 18:36:55 +0100] debug/LegacyTimePeriod: ParseTimeRange: 'thursday' => 1514415600 -> 1514502000, stride: 1
    3. [2017-12-26 18:36:55 +0100] debug/LegacyTimePeriod: ParseTimeRange: 'tuesday' => 1514847600 -> 1514934000, stride: 1
    4. [2017-12-26 18:36:55 +0100] debug/LegacyTimePeriod: ParseTimeRange: 'wednesday' => 1514329200 -> 1514415600, stride: 1
    5. [2017-12-26 18:36:55 +0100] debug/LegacyTimePeriod: Legacy timeperiod update returned 2 segments.
    6. [2017-12-26 18:36:55 +0100] debug/TimePeriod: Removing segment 'Tue Dec 26 18:36:55 2017' <-> 'Wed Dec 27 18:36:55 2017' from TimePeriod '9to5'
    7. [2017-12-26 18:36:55 +0100] debug/TimePeriod: Adding segment 'Tue Dec 26 09:00:00 2017' <-> 'Tue Dec 26 17:00:00 2017' to TimePeriod '9to5'
    8. [2017-12-26 18:36:55 +0100] debug/TimePeriod: Adding segment 'Wed Dec 27 09:00:00 2017' <-> 'Wed Dec 27 17:00:00 2017' to TimePeriod '9to5'
    9. [2017-12-26 18:36:55 +0100] information/ConfigItem: Activated all objects.
    10. [2017-12-26 18:36:55 +0100] notice/WorkQueue: Stopped WorkQueue threads for 'DaemonCommand::Run'


    Also die Zeile, die im Unit-File steht.

    Der Icinga2 Prozess ( eigentlich sind es 2) läuft dann im Hintergrund weiter.