cannot open shared object file (Error while starting monitoring-instance)

This forum was archived to /woltlab and is now in read-only mode.
  • Hello,


    i have a fresh install of the latest raw version of check mk on a ubuntu 16.04.03 server. i do this to finish my education as IT specialist(system integration). On the first day, the graphs are shown at a few services, but at this time there are only red blocks with error messages of:

    ERROR: STDERR = > /omd/sites/monitoring/bin/rrdtool: error while loading shared libaries: libpng16.so.16: cannot open shared objekt file: No such file or directory


    I have tried to manually check the mistake, but i dont find any solution in the internet -.-

    if i typ via putty "omd start monitoring"

    It says, that all the services are running but one error occurs:

    Starting rrdcached.../omd/sites/monitoring/bin/rrdcached: error while loading sh ared libraries: libpng16.so.16: cannot open shared object file: No such file or directory

    Error


    I have updated the packages and reinstall libdbi-dev libdbi-perl but there is no effect. Same problem. Also i have thinked, okay restarting the server may helps by this problem, but computer says no and if i log in to check mk im getting errors while loading the dashboard. I have restored a snapshot, but i still know, if i restart the server the system is not able to work good.


    Hope anyone can help me because this monitoring system is my finally project in my education :o

  • The cause of the error message is a missing library.


    Check the following:


    Code
    1. ldd /omd/sites/monitoring/bin/rrdcached

    This should give you at least one error message.


    Figure out to which Debian Package the files belong to(with dpkg -S or apt-file) and install(if installed --> reinstall with apt-get install --reinstall ) the package.

  • the one error messages is: libpng16.so.16 => not found


    apt-file libpng16.so.16 only shows the apt-file help


    dpkg -S libpng16.so.16

    dpkg-query: Kein Pfad gefunden, der auf Muster *libpng16.so.16* passt


    In English: No Path is found matching the pattern *libpng16.so.16*


    But i know, which packet is missing



    /edit: i installedlibpng16-dev and now it works. Very thanks, you safe my ASS!