icingaweb2 not working

This forum was archived to /woltlab and is now in read-only mode. Please register a new account on our new community platform.

You can create a thread on the new site and link to an archived thread. This archive is available as knowledge base, safe and secured.

More details here.
  • Please provide more insights into your setup, how you've installed these applications, following which guides, etc.


    https://monitoring-portal.org/cms/index.php?faq/

  • oot@icinga-test:~# tail -f /var/log/apache2/error.log


    [Tue Oct 31 15:44:48.608126 2017] [core:notice] [pid 23794] AH00094: Command line: '/usr/sbin/apache2'


    [Tue Oct 31 15:44:49.777036 2017] [mpm_prefork:notice] [pid 23794] AH00171: Graceful restart requested, doing restart


    [Tue Oct 31 15:44:49.832764 2017] [mpm_prefork:notice] [pid 23794] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations


    [Tue Oct 31 15:44:49.832778 2017] [core:notice] [pid 23794] AH00094: Command line: '/usr/sbin/apache2'


    [Tue Oct 31 15:55:10.680451 2017] [mpm_prefork:notice] [pid 23794] AH00169: caught SIGTERM, shutting down


    [Tue Oct 31 15:55:11.802795 2017] [mpm_prefork:notice] [pid 24221] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations


    [Tue Oct 31 15:55:11.802828 2017] [core:notice] [pid 24221] AH00094: Command line: '/usr/sbin/apache2'


    [Tue Oct 31 16:03:44.049095 2017] [mpm_prefork:notice] [pid 24221] AH00169: caught SIGTERM, shutting down


    [Tue Oct 31 16:03:45.182726 2017] [mpm_prefork:notice] [pid 24478] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations


    [Tue Oct 31 16:03:45.182762 2017] [core:notice] [pid 24478] AH00094: Command line: '/usr/sbin/apache2'


    I also followed this instruction on how to install icinga

    https://www.digitalocean.com/c…cinga-web-on-ubuntu-16-04

  • thats look like an apache missconfiguration


    please try first this

    Code
    1. apache2ctl configtest

    then, look, which apache mpm are installed:

    Code
    1. /usr/sbin/apache2 -V | grep MPM


    (sorry, i use primary nginx, thats was (and is) easesier for me ;) )

  • code 1

    apache2ctl configtest


    Syntax OK


    code 2

    usr/sbin/apache2 -V | grep MPM


    bash: usr/sbin/apache2: No such file or directory

  • ohh ... hirn
    please ... use your brain and not copy-paste! :)

    add a slash in front of usr: /usr/sbin/apache2 -V | grep MPM

  • | reinstalled apache ,icinga and icingaweb again after uninstalling all

    I can now reach the http://x.x.x.x/icingaweb2

    but i have an issue setting up the web

    I cannot seems to validate the IDO resources as in this attachment

    I tried this command which import the icinga 2 IDO schema

    mysql -u root -p test123 < /usr/share/icinga2-ido-mysql/schema/mysql.sql


    and the result

    [5] 3688


    Usage: lt `parameters' [versionkey]


    computes the n-point one-loop integrals


    n depends on `parameters':


    n = 1: m


    n = 2: p m1 m2


    n = 3: p1 p2 p1p2 m1 m2 m3


    n = 4: p1 p2 p3 p4 p1p2 p2p3 m1 m2 m3 m4


    n = 5: p1 p2 p3 p4 p5 p1p2 p2p3 p3p4 p4p5 p5p1 m1 m2 m3 m4 m5


    versionkey can be one of:


    0 = compute version a (same as no versionkey)


    1 = compute version b


    2 = compute a and b, compare, return a


    3 = compute a and b, compare, return b

    [5]+ Stopped mysql -u root -p test123


    /usr/share/icinga2-ido-mysql/schema/mysql.sql: line 1: --: command not found


    /usr/share/icinga2-ido-mysql/schema/mysql.sql: line 2: --: command not found


    /usr/share/icinga2-ido-mysql/schema/mysql.sql: line 3: --: command not found


    /usr/share/icinga2-ido-mysql/schema/mysql.sql: line 4: --: command not found


    /usr/share/icinga2-ido-mysql/schema/mysql.sql: line 5: syntax error near unexpected token `('


    /usr/share/icinga2-ido-mysql/schema/mysql.sql: line 5: `-- Copyright (c) 2009-2016 Icinga Development Team (https://www.icinga.com/)'

    Here is also my MySQL.sql file in my attachment

  • /usr/sbin/apache2 -V | grep MPM


    [Wed Nov 01 17:26:41.663193 2017] [core:warn] [pid 4145] AH00111: Config variable ${APACHE_LOCK_DIR} is not defined


    [Wed Nov 01 17:26:41.663229 2017] [core:warn] [pid 4145] AH00111: Config variable ${APACHE_PID_FILE} is not defined


    [Wed Nov 01 17:26:41.663239 2017] [core:warn] [pid 4145] AH00111: Config variable ${APACHE_RUN_USER} is not defined


    [Wed Nov 01 17:26:41.663242 2017] [core:warn] [pid 4145] AH00111: Config variable ${APACHE_RUN_GROUP} is not defined


    [Wed Nov 01 17:26:41.663249 2017] [core:warn] [pid 4145] AH00111: Config variable ${APACHE_LOG_DIR} is not defined


    [Wed Nov 01 17:26:41.669403 2017] [core:warn] [pid 4145] AH00111: Config variable ${APACHE_LOG_DIR} is not defined


    [Wed Nov 01 17:26:41.669493 2017] [core:warn] [pid 4145] AH00111: Config variable ${APACHE_LOG_DIR} is not defined


    [Wed Nov 01 17:26:41.669501 2017] [core:warn] [pid 4145] AH00111: Config variable ${APACHE_LOG_DIR} is not defined


    AH00526: Syntax error on line 74 of /etc/apache2/apache2.conf:


    Invalid Mutex directory in argument file:${APACHE_LOCK_DIR

  • it worked

    mysql -u root -p test123 < /usr/share/icinga2-ido-mysql/schema/mysql.sq but used icinga2 instead of test123

    it ask me for password

  • [1698] Access denied for user 'root' localhost

    It's a permission problem: The Userroot is not allowed to access your database. Please have a look at your user settings. It isn't a good idea to use your database administrator account for an application. Best practise is to create a separated user.


    Please have a look at the Icingaweb2 documentation!

  • Code
    1. Connection failed SQLSTATE[HY000] [1045] Access denied for user 'icinga2'@'localhost' (using password: YES)

    I am not sure what I did wrong when setting up icinga web2

    This is the error message when setting up the web trying to validate the IDO configuration during the web setup

    Please can you help

  • test your database connection via command-line.


    mysql -uroot -p -h localhost ...

    mysql -uicinga2 -p -h localhost ...


    please use the correct passwords!


    if this fails, configure the database properly


    but ... you should learn the basics before doing anything more complex!