icinga service seems to be stuck, for certain zones

This forum was archived to /woltlab and is now in read-only mode.
  • I have a single master with 4 satellite zones. Each of those zones has 2 satellites. I was getting a error on all of my satellites "Last reload attempt failed". In order to get the service started again I had to fix the configuration files in the master zone then manually delete all the files in /var/lib/icinga2/api/zones/ on each of the satellites, then start everything back up and them sync.


    After doing that everything worked, all services checks, and client checks. The only thing that never changed was the warning "Icinga 2 has been running for 46 minutes and 2 seconds. Version: r2.7.1-1: Last reload attempt failed at 2017-10-28 22:44:35 -0400". All Satellites are running without issue and the really strange thing is in icingaweb2 UI it shows the last service check of 2017-10-28 22:44:35, but it is now 14 hours later and the last check never changes.


    I tried doing "check now" and "reschedule check", same results, still shows 2017-10-28 22:44:35 as last check. I tried removing the host, removing the service, deleting the /var/lib/icinga2/api/zones/ contents, but no changes.


    After I chose check now, it shows in the log the command was sent.


    cat /var/log/icinga2/icinga2.log | grep bear-island

    I am not sure where to go from here, thanks for any help you can give.

  • Which exection time did your specify for the service ?


    Can you please post the oupt put from "icinga2 object list --name=*$SERVICE$* --type=service"

  • I am not sure what you are looking for exactly, but I think this is output that is pertinent.

  • Okay thanks for information, I will read it over again, see what I missed.

  • I figured this out. Just in case anyone else has the same issue, the issue was in the host record.


    I changed

    Code
    1. check_command = "cluster-zone"

    to

    Code
    1. check_command = "hostalive"