A simple created check in Director lead to the validation error "Object 'mail-host-notification' of type 'NotificationCommand' does not exist"

This forum was archived to /woltlab and is now in read-only mode.
  • Dear Icinga-Community,

    due to a lot of problems in the past with notifications I dropped my current Icinga2+Director environment and set it up once again with Icinga2 (v 2.7.0-1) and Director (1.3.2 from tarball). To get a proper and stable system I followed the latest video tutorial for Director ( Icinga Director: Installation und Einrichtung (Teil 1) (Webinar vom 28. Juni 2017) ). All looks fine until I created the first notification check to receive an email if the host goes down or up. The validator failed with:

    Currently I've only one simple host. To identify the identification type I added a data list.

    1. object Host "xxxx.xxxxxxx.com" {
    2. import "generic-hosts"
    3. display_name = "TS Icinga Monitoring Host"
    4. address = ""
    5. groups = [ "tsu" ]
    6. vars.notification = "email"
    7. }

    For notifications I created following objects in Director:

    • a time range template
    • a time range object with all the time ranges
    • a user template
    • a group and user object
    • a notification template for host notification
    • and the following notification object
    1. apply Notification "check-hosts" to Host {
    2. import "first-level-host-tmpl"
    3. assign where host.vars.notification == "email"
    4. states = [ Down, Up ]
    5. types = [ Problem, Recovery ]
    6. user_groups = [ "first-level-grp" ]
    7. }

    Can anybody give me a hint how to solve the problem?

    Thanks in advance and best regards,


  • the director tells you, that there is no command with this name.

    I would also advise you to use 1.3.1 of the Director as 1.3.2 is still tagged as prerelease

    Linux is dead, long live Linux

    Remember to NEVER EVER use git repositories in a productive environment if you CAN NOT control them

  • Dear Kevin,

    thanks for your reply. I still know that Icinga have trouble with the command but what is the reason for?

    I'm still working since several weeks (not the whole time ;)) on Icinga and try to get it running. The concept of the product, the ui and all its modules is great and I love it but for me it's not possible to get it final running with notifications (BTW I followed also your tutorial without success). Now I installed a clean and, from my point of view, non-spectacular installation and I stuck once again. In addition the latest Director video tutorial ends in front of the topic 'notifications'. Bad!

    Can anybody tell me why the command is not known for Director? Has anybody got notifications working without move Director inside out? Could it be really a problem of the pre-release of Director?

    If the community needs more information I will provide.

    Thx, Ray

  • I do have notifications running with the Director.

    The notification commands I use, are the default ones, with slightly adapted templates.

    Take a look at the command section in the Director and search for notifuication, the default commands should pop up, if they don't just define your own.

    Icinga2 does serve 2 default shell scripts in this location:


    Linux is dead, long live Linux

    Remember to NEVER EVER use git repositories in a productive environment if you CAN NOT control them

  • Dear Wolfgang, dear Kevin,

    first of all thank you both to lead me on the right path. I've solved the problem!

    The reason for this problem was, that Christian Stein recommended in his latest video tutorial 'Icinga Director: Installation und Einrichtung' after installation of the director module to delete all conf-files under '/etc/icinga2/conf.d/' expect of 'api-users.conf'. I followed this guide and of course I deleted also the file 'command.conf'. After restore this file and start the kickstarter now it works.

    Thanks for your support, Ray