host and services are not accessible after upgrade to 1.3.2

This forum was archived to /woltlab and is now in read-only mode.
  • Dear Icinga-community,

    I use:

    Icinga2: 2.6.3

    Director: 1.3.2

    Due to many trouble with notifications under Icinga Director 1.3.1 I upgraded to the pre release version 1.3.2. Unfortunately now my host and service definitions are no longer accessible. If I want to access the following message appear:

    Trying to set invalid icinga_service key "check_timeout". DB schema change?

    I ran 'icingacli director migration run --verbose' without success. Is there any migration script for the database available?

    BTW: I've seen Icinga 2.7 was rolled out. Is there something special to take care or can I proceed the existing documentation under '' ?

    Thanks in advance and best regards,


  • Mh, did you use 1.3.1 from tarball, or git master? There might be some problems here.

    2.7 includes changes to the notification scripts and other new features, make sure to read the Changelog and release blogpost prior to upgrading. A test lab with an upgrade will certainly help too :)

  • Dear dnsmichi,

    thanks for your reply. I used the tarball from ''. Is there any difference between tarball and git repo?

    Best, Ray

  • I just wanted to be sure about it. I have seen users telling me they use 1.3.x and when I asked about the installation method, it was like "wget

    Git master is always a development branch, and in flux. You shouldn't put that into production, unless you know what you're doing.

    Did a short grep in the sources, the v1.3.2 tag does not contain "check_timeout" at all. That column only exists in git master. Seems you have a mix running here, probably a git master deployed which talks to an old schema, or so.

  • I checked out the current git version from Director and it seems to work now.

    When do you think a proper documentation for upgrading all to 2.7 will be available?

    Thanks for your quick support and all the best,


  • What do you mean by "proper documentation"?

    Imho a software upgrade involves reading the Changelog and then taking care about possible changes. Does that need extra docs? :)

  • i have exactly same problem, update director 1.3.1 to 1.3.2 and getting same error.

    I did update it as tar.gz file, not master git.

    Can u please point me what did u do? do get it working agian??

  • Dear Renzzoo,

    in my case I installed Icinga2 version 2.7 new from scratch. Afterwards I installed the latest Director plugin (version 1.3.2) from tarball and it works. The only trouble I had was the problem with the notification due to I followed the latest video tutorial to get the Director running. I solved it (see: A simple created check in Director lead to the validation error "Object 'mail-host-notification' of type 'NotificationCommand' does not exist").

    Best, Ray