Up/Downgrade check_mk 1.2.6p12check_mk 1.4.0p5.cre

This forum was archived to /woltlab and is now in read-only mode.
  • Hallo zusammen,


    habe aktuell die omd 1.30 mit check_mk 1.2.6p12 am laufen und würde auf die aktuellere check_mk check_mk 1.4.0p5.cre upgraden wollen.


    Das Upgrade an sich verläuft auch soweit ganz gut, nur habe ich Probleme für den Fall der Fälle wieder auf die frühere Version zu wechseln. Das Inventarisieren funktioniert nicht mehr korrekt und auch die bisherigen Services lassen sich nicht anzeigen.


    Code
    1. Invalid configuration variable 'mkeventd_enabled'
    2. --> Found 1 invalid variables
    3. If you use own helper variables, please prefix them with _.


    Hat das schon wer erfolgreich hin bekommen?


    Beim letzten Versuch habe ich schon extra alle Dateien behalten, aber es kommt immer nur zu diesem einen Fehler.

  • Mit welchen Schritten wechselst du denn wieder zur früheren Version zurück?


    mkeventd über omd config yoursite könntest du auch mal probieren mkeventd zu disablen und dann wieder zu enablen.

  • Code
    1. omd update <site name>


    Start/Stop von mkeventd bringt auch keine Abhilfe.


    Was mich verwundert, es ist nur ein Testsystem mit einem frisch installierten omd 1.30 und einer Testseite. Es wurde lediglich dann das Upgrade auf die raw 1.4 gemacht, Testseite auf die neue Version umgestellt und dann wieder zurück auf die alte Version. Das sollte ja ohne Probleme möglich sein ...

  • Das sollte ja ohne Probleme möglich sein ...

    Das Update vielleicht. Aber ein Downgrade zu einer früheren Version kann, wie ja in deinem Fall, durchaus zu Problemen führen, wenn da neue Pfade, Variablen, etc. dazukommen. Ich persönlich würde ein omd backup der alten site machen und wenn mir die neue Verison nicht gefällt, die site löschen und wieder aus dem backup herstellen.


    Die andere Möglichkeit wäre, die mkeventd.mk configs unter .../etc/check_mk/conf.d und multisite.d zu löschen bzw. die Variable da rauszunehmen.

  • Mensch, darauf hätte ich auch kommen können.


    In der mkeventd.mk steht ja wirklich nur eine Variable drin. Nach Entfernung/Auskommentierung funktioniert nun auch wieder alles wie gewohnt.


    Danke!

  • Nachtrag


    Mir scheint die Lösung mit dem Backup die einzig wahre zu sein.


    Es treten einfach zu viele Fehler auf beim wechseln der Versionen einer Seite.


    Hinweis: Ggf. muss die default Version wieder geändert werden für die Wiederherstellung


    Code
    1. omd setversion <version number>