check_sap ResponseTime No Performance Data

This forum was archived to /woltlab and is now in read-only mode.
  • Hallo zusammen,


    ich hoffe ich bin hier im richtigen Unterforum. Habe trotz intensiver Suche leider nichts zu diesem Problem gefunden.


    Wir überwachen unsere SAP Systeme mit check_sap. Soweit so gut, ich kann die Availability oder auch die UsersLoggedIn abrufen und erhalte dafür auch Performance Daten die ich dann wiederum in Grafana verwursten kann.

    Wenn ich die ResponseTime abrufe, egal ob heruntergebrochen auf ResponseTimeDialog oder einfach alle Responsetimes bekomme ich im Icingaweb2 zwar die Zeiten angezeigt:


    [OK] [...]Dialog/ResponseTime: 478 msec
    [OK] [...]/Dialog/ResponseTimeDialog: 457 msec
    [OK] [...]/Dialog/ResponseTimeDialogRFC: 538 msec
    [OK] [...]/Dialog/ResponseTimeHTTP: 170 msec
    [OK] [...]/Dialog/FrontendResponseTime: 660 msec


    Allerdings wird mir unter Performance data neben dem Label nur der Wert 0.00 angezeigt.


    Mache ich hier einen Fehler in der Abfrage? [check_sap [...] 'SAP CCMS Monitor Templates' 'Entire System' 'ResponseTime' -f]


    Oder hat hier das Plugin oder Icinga2 ein Problem? Liegt es eventuell daran das der Wert in "msec" anstatt "ms" zurück gegeben wird?


    Edit:

    check_sap_health das ich als Alternative betrachtet hatte liefert mir beim Check der ResponseTime nur ein OK und gar keine Zeitangabe. Gibt es hier vielleicht eine Idee?


    check_sap_health liefert nun Performance Data.


    Zumindes habe ich jetzt Performance Daten, wenn auch nicht aus check_sap. Solved.