how to Configure Mail Notification with icinga2

This forum was archived to /woltlab and is now in read-only mode.
  • hi dnsmichi

    I'm having an issue with setting up notifications in Icinga2.I restarted Icinga2, my configuration is not blowing up when I restart, but I am not getting any notifications.

    i installed external smtp server.but iam not getting any mail alerts.

    please help me.

  • sparton , if you want dnsmichi to see your post you need to prepend its name with an '@' - sign.


    Regarding your issue, i would start with interpreting the logs /var/log/icinga2/icinga2.log and /var/log/icinga2/debug.log,

    the later to be switched on using icinga2 feature enable debuglog && service icinga2 reload.


    Do not forget to disable the debuglog as soon as possible to avoid a full harddisk.

  • Well, if you are in such a hurry, please be so kind and provide more details (versions, configs, logs, etc.).


    Some of us are not reading and replying 24/7 here and even if, that's for the fun and pride. As such please don't stress it. Postings on my profile wall do not speed things up - I think that's fairly impolite to do so, unless it is an administrative issue on the forum software itself.

  • hi everyone could you help me ,

    how can i get email notifications of icinga2 .

    i installed external smtp server on centos7 .i installed icinga2 and icingaweb2 .

    but i put my mail id in users.conf file.

    please help me anyone how can i fix this issue.

  • As i told you in post #2, you should enable the debug.log.

    Then, using icingaweb2, pick some host and hit "Send Notification".


    Find that notification in the log file and post that snippet here.


    Show the hosts config along with what is in the users.conf file.

  • I dare saying there's not much more in place despite "installing external SMTP server" whatever that means in detail.

    sparton : Notifications need to be set up in Icinga. Without that, even debug.log won't show much. On top, if you run on default config, your local root alias might not be assigned mailwise meaning this account might have local mail.

  • Notifications need to be set up in Icinga. Without that, even debug.log won't show much

    They are configured by default - and chances are he did not found how to break them yet :D

    your local root alias might not be assigned

    :thumbup:Thats why i want the log snippet.