Kickstart Wizard Error: "Failed to load icinga_zone "master""

This forum was archived to /woltlab and is now in read-only mode.
  • Hello everyone,

    I just tried to install and activate the icinga2-Director-Module.

    Everything has worked fine so far, until I wanted to run the import in the Kickstart Wizard.

    It tells me: "Failed to load icinga_zone "master""

    Everything I have found on the web tells me that this was a known bug in version 1.0.0, but I am on 1.3.1.

    Is anyone by any chance familiar with this problem?



  • This is what my zones.conf looks like:

    And this is what the Kickstart Wizard looks like when im tyring to ... well... kickstart it

    The password is inserted correctly before i click "import"

    // Edit: falls jemand nicht auf English antworten möchte, ihr könnt auch gern auf Deutsch oder Französisch antworten, Hauptsache ich krieg
    dieses Problem gelöst.

  • I have the same issue at the moment. When I run the command line:

    ERROR: Icinga\Exception\NotFoundError in /usr/share/icingaweb2/modules/director/library/Director/Data/Db/DbObject.php:589 with message: Failed to load icinga_zone "master"

    Also, when I click 'Activity Log' in the web interface, I get the error like the attachment. I am trying to use automation, hence, I don't want to use kickstart wizard on the web (I already created kickstart.ini file). I configured a distributed model. Is this the reason?

  • I had the same issue when using the most recent state of the git master branch.
    Switched back to the last tagged version (v1.3.1) and the import seems to be working now.

  • Well, I am using v1.3.1 but got the issue. I had set the distributed model (6.10.2 in Iginga2 documentation) before installing icingaweb2 and director. Is there a specific order I should follow? Or am I missing something e.g. directory permission setting?

  • Just downloaded the latest git and tried again, the same result. Anyone can have the same issue? I am trying to automate the procedures through Ansible as possible as I can and I got stuck here.

  • Hi,

    I have spent already few hours to figure out the reason of this issue but no luck so far. Therefore, I am thinking about building from scratch. It's not that difficult as I am using Ansible. But I want to make sure this time about the order. So, this is what I think as the order:

    1. Icinga2 install/configuration

    2. Icingaweb2 install/configuration

    3. Icingaweb2 director install/configuration

    4. Icinga2 clustering

    Am I going on the right track? I will try with 2 master nodes and 1 client. Meanwhile, if someone finds the cause of this issue, please let me know. I'll really appreciate it. Thanks a lot.

  • Yeah same problem here:

    "Failed to load icinga_zone "master" (DbObject.php:589)"

    Authentication to the API works (i put the api-users.conf in my zones.d/master/ , hope thats correct) but afterwards it fails with the message above.

    The command:

    curl -k -s -u director:secret 'https://localhost:5665/v1/objects/zones/master'

    works fine.

  • Just looked inside the director database. The icinga_zone table doesn't include master zone. Is this the reason why I get the error?

    MariaDB [director]> SELECT * FROM icinga_zone;


    | id | parent_id | object_name | object_type | disabled | is_global |


    | 1 | NULL | director-global | external_object | n | y |

    | 2 | NULL | global-templates | external_object | n | y |


    2 rows in set (0.00 sec)

    MariaDB [director]>

  • Okay, here's what I've found. When I looked into the director database the master zone is registered as an object. I manually changed this to external_object and did the same for endpoints in the master zone. (icinga_zone, icinga_endpoint table each). After this change has been made, I ran kickstart and it worked.

  • I´ve got the same error. But i couldn´t find the master zone in the director database. How can i solve this issue?

  • I´ve got the same error. But i couldn´t find the master zone in the director database. How can i solve this issue?

    Hi mate,

    So, what I have done is:

    1. Creating the endpoints and master zone manually via command line:

    - icingacli director endpoint create ENDPOINT --host IPADDR --port 5665

    - icingacli director zone create master

    2. Update endpoints manually:

    - icingacli director endpoint set ENDPOINT --zone master

    After this, I could see the master zone (icinga_zone) and its endpoints (icinga_endpoint) in the director database. Then, I updated the data. I am not sure this is the correct way to resolve the issue but this is the only working solution for me so far.