Icinga2 checks and hostcheck not turning critical.

This forum was archived to /woltlab and is now in read-only mode.
  • Hi Icinga-Community,


    i am new to icinga2, but have worked with nagios/icinga. Now i figuring out the new version - but i run in to some problems where i would like to ask for help since the docs not turn me in any better direction.


    I have a icinga2 based installation bootstrapped with saltstack. A centos installation based on the icinga pkg's supplied by the icinga2 rpm repositories.


    One master and two clients, no satellite in between. I'm using Top-Down/Config-Sync, all of the zone and sync features work as expected. I also get check results from the correct remote systems.


    For now i have the following problem:


    If i shut down one of my icinga agents or a services that should be supposed to to be checked and get critical on fail, the service turns red at "Last check" in icingaweb interface but doesn't turn critical, also the check attempts does not enumerate. i included the cluster-check and this one is reporting correctly if i turn of the icinga agent.

    File-Listing

    Master

    Agent

    I already compared my file rendering to those used in puppet/vagrant
    environment supplied on github, but i can't figure it out myself.


    Any hints? Thanks in Advance.


    Greetings,

    Sebastian

  • Damn, i always tell myself to recheck after night shifts 8o


    I just found out that my test was not valid. I expected all checks to get critical if icinga-agent is down, but that doesn't seem to be the default behaviour. The following


    So the thread is resolved.


    Thanks anyway.