Module: NagVis - "not authenticated"

This forum was archived to /woltlab and is now in read-only mode.
  • Hello everyone,

    as I was to trying to set up NagVis in Icingaweb2 I encountered a problem.

    When I try to enter NagVis it tells me "not authenticated".

    When configuring NagViz I sticked closely to the specified README:

    I have already discovered threads with people having the same problem but they are usually able to fix it, by doing nothing more than adding the infamous "[cookie]"-Section to their icingaweb2 config.ini.

    I am a little lost at the moment, because I am not sure what else I can try. I have already deleted the cookies and tried it on several browsers, but there is still something wrong obviously.

    Maybe someone does have an example Config he would like to share or something similar...

    If you need any further information, let me know.

    Thanks in advance,

    Ruven Graf

  • Did you modify the mentioned functions/index.php at the bottom of the docs? That is required to forward the session from Icinga Web 2 to NagVis as embedded module.…gvis#php-code-integration

  • Did you modify the cookie path? You'll then need to clear your browser cache, especially the local cookies (and of course log out of Icinga Web 2).

  • Another thing i have noticed, is that when i call the servers "root-page": http://FQDN

    It shows me this:

    And it doesn't matter which one im opening, they all promt a login except (who wouldve guessed) nagvis.

    It says: "not authenticated"

    What I also tried, was to log on from a newly installed computer to avoid any kind of stored cookies, but there was no success either...

    same message.

    This really has got to do something with the cookie path, doesn't it?

    What I have also noticed, is that the nagvis directory is the only one with different permissions on it in the /usr/local/ dir:

    Everything in it belongs to www-data (the apache user)

  • This is driving me crazy, I just can't find the reason why this doesnt work...

    Its throwing me out at this point:

    Is there any way to check if the cookie path works? Do I have to activate it somehow?

    Thsi is again how it looks... as it should in my opinion.

    Another thing, in the doc it say that I have to cofigure "ndomy_1" as backend, that doesn't really work for either, but thats a minor problem I guess since I can't even get in.

    Oh, and can someone move this thread to the modules category?

    // Edit: falls jemand nicht auf English antworten möchte, ihr könnt auch gern auf Deutsch oder Französisch antworten, Hauptsache ich krieg dieses Problem gelöst.