Shows "Error: Could not read object configuration data!" for Availability report

This forum was archived to /woltlab and is now in read-only mode.
  • I have icinga2 and icingaweb2 installed & configured at CentOS 7 with pnp4nagios.. while i am clicking the option "Availability report for this time range or Most recent alerts for this time range" from pnp4nagios graph its shows "Error: Could not read object configuration data!" ... regarding this i didnt get anything at icinga2 debug log or apache error log or pnp4nagios log ...


    Versions of the packages are :

    icinga2-2.6.2

    icingaweb2-2.4.1-1

    pnp4nagios-0.6.25-1

    CentOS Linux release 7.3.1611


    At my system apache user is the group member of icinga daemon user and also permission & ownership is set to user & group same for pnp4nagios directory....


    I have found something similar but that was 2 years old and there it has been said that avail.cgi is not supported at icinga2 or icingaweb2...


    Can anyone help me to find out the reason behind this problem & resolve the issue or i am going for wrong options !!!

  • while i am clicking the option "Availability report for this time range or Most recent alerts for this time range" from pnp4nagios graph its shows "Error: Could not read object configuration data!"

    PNP links back to the CGIs which aren't available in Icinga2.

  • That is what i already knew.. as i have already searched & seen this issue in a 2 years old thread...


    I was actually searching for any tricks/tips to resolve it.... And as i am not a developer, so that i am not able to help on this matter... rather than i am seeking help ....


    Now i think i need to wait for this ... :|