cluster-zone Check

This forum was archived to /woltlab and is now in read-only mode.
  • Hallo Icinga-User,


    Meine Frage bezieht sich auf den Check "cluster-zone" bezüglich der Statusmeldung Log-Lag.


    Das Setup besteht aus einem Cluster mit zwei Nodes (Icinga2a, Icinga2b). Sie bilden die Zone "config-ha-master". Nun möchte ich mit dem "cluster-zone" Check, genau diese Zone überprüfen.


    Die Ausgabe des Checks lautet wie folgt:


    Icinga2a: Zone 'config-ha-master' is connected. Log lag: less than 1 millisecond

    Icinga2b: Zone 'config-ha-master' is connected. Log lag: 10 days, 16 hours, 26 minutes and 49 seconds



    Warum ist der Log Lag auf Icinga2b so hoch, bzw. steigt stetig an?


    Der Check wurde wie folgt konfiguriert:



    Vielen Dank für eure Hilfe

  • hast du schon mal in die logs geschaut, ob da irgendwelche fehler auftreten?

    Das hört sich für mich danach an, als ob da was nicht sauber läuft

    Linux is dead, long live Linux


    Remember to NEVER EVER use git repositories in a productive environment if you CAN NOT control them

  • Ich habe mir mal die Logs angeschaut und leider nichts richtiges gefunden: Hier die Ausgabe des debug.log und des EventStreams:



  • Update:


    Wo liegt der Fehler?!


    Habe den selben Service nun folgendermaßen angehangen; Anstatt einem Apply Service ein Object Service.



    Die Ausgabe des Checks:

    Icinga2b: Zone 'config-ha-master' is connected. Log lag: less than 1 millisecond


    Was mache ich falsch, was ist falsch oder wie kommt dieses Verhalten zustande?