Automating client install on Windows

This forum was archived to /woltlab and is now in read-only mode.
  • Hi,

    I have read many forums but am unable to work out all the steps to configure a Windows Icinga2 client without using the GUI.

    I have used the steps here: Icinga2 with manual setup and communication from the master to the windows client only

    but am unable to get my client showing in Icinga.

    On another client I have set it up with the GUI and compared all files in C:\ProgramData\icinga2\etc\ and made sure my manually configured client has the relevant changes but it still does not show when restarting my Icinga2 master.

    Can you point me to some details instructions or advise if what I am doing is even possible.

    Thank you in advance for your responses.

  • The post you refer to may be a bit outdated. for example, there are files in c:\ProgramData\icinga2 noadays.

    • Did you manage to install the msi so that the service is already installed and running ?
    • Did you poke a hole in your firewall at tcp 5665 ?

    • On both clients, icinga2 feature list returns the same ?
    • On the master, do you see the manual client using icinga2 node list ?
    • Only if it is listed, does it work after icinga2 node update-config ?

    If it is not listed, recheck:

    • directory entries of /etc/inicinga2/pki
    • contents of /etc/icinga2/constants.conf and /etc/icinga2/zones.conf
    • /var/log/icinga2/icinga2.log on client and master

    If that still does not reveal the problem, switch on the debug log:
    icinga2 feature enable debuglog && service icinga2 restart
    check /var/log/icinga2/debuglog.

    The post was edited 3 times, last by sru ().

  • Hi Sru,

    Thanks for the suggestions - I found that my manually configured working client has api enabled and it was not enabled in my remote setup one.

    I enabled the api with icinga2 feature enable api and then restarted the icinga2 service in Windows.

    I ran the icinga2 node list command but still it did not show up.

    I ran icinga2 node update-config and restarted icinga2 master and now it shows up in my web interface.

    Thanks for your help.