rsyslog-Problem beim Reporting an Syslog-Server

This forum was archived to /woltlab and is now in read-only mode.
  • Hallo allerseits!


    Ich habe drei Debian-Server, die an meinem Problem beteiligt sind:


    alter Server: Debian 2.6.32-5-amd64, rsyslogd 4.6.4
    neuer Server: Debian 3.2.68-1+deb7u1 x86_64, rsyslogd 5.8.11
    Monitor: Debian 3.2.60-1+deb7u1 x86_64, rsyslogd 5.8.11


    Der Monitor dient als Syslog- und Monitoringserver, was von diversen Geräten (Switches, USV's, etc.) und Servern (Windows/Linux) erfolgreich genutzt wird. Die anderen beiden sollen Ihre Logs an den Monitor schicken. Die Logs werden auf dem Monitor einerseits von Octopussy verarbeitet andererseits aber auch noch mal in IP-Spezifische Logdateien geschrieben.


    Die rsyslog.conf auf den beiden Servern sind gleich ausser dass der neue Server einen Eintrag für ein Spool-Verzeichnis hat.
    das Verzeichnis rsyslog.d ist bei beiden leer
    Beim alten Server sorgt der Eintrag in der rsyslog.conf

    Code
    1. # Provides TCP forwarding to the Monitoring-Syslog-Server.
    2. *.* @@192.168.178.10:514


    dass alle Log-Meldungen auch an den Monitor geschickt werden. Der selbe Eintrag in der rsyslog.conf auf auf dem neuen Server legt lediglich das Logging lahm, ohne dass da irgend eine Fehlermeldung kommt. Lediglich die Meldung über den Neustart des rsyslogd landet noch im syslog, aber auch nicht auf dem Logserver. Nehme ich den Eintrag aus der Config wieder raus (auskommentieren reicht immerhin) landen wieder im 1/10 Sekunden-Takt die Meldungen im lokalen Syslog.


    Hat irgend jemand eine Idee, was da schief laufen könnte?


    Gruß, Felix.