Tastatur Layout OpenSuse 11.2

This forum was archived to /woltlab and is now in read-only mode.
  • Hallo.


    Habe seit kurzem ein Problem mit meinem Tastatur Layout in OpenSuse 11.2. Obwohl alle Einstellungen auf Deutsch eingestellt sind und auf Dell-Tatastaturen, stehen mir nicht mehr alle Zeichen zur Vefügung.


    Als Beispiel fehlen die Zahlen: 2367890


    Die Zeichen sind fast alle am falschen Platz


    und das z und y sind vertauscht, was ja irgendwie ein amerikanisches layout vermuten lässt.

    The post was edited 1 time, last by NagLiz ().

  • Nicht, daß ich da schonmal tiefergehend 'rumgespielt hätte, aber ...

    • Sprechen wir von einer Konsole (Klötzchenkunst grauschwarz) oder einem Terminalfenster in der GUI?
    • Was steht denn so in /etc/sysconfig/keyboard ?
  • Hab dir die datei mal abfotographiert :) kann sie leider ned direkt hochladen, weil ich nichtmal das passwort für den internetzugang auf der kiste eingeben kann :(


    handelt sich um openSuse mit oberfläche...also hab ich auch versucht an den systemeinstellungen rumzudrehen und in yast gesucht aber nicht fündig geworden...

  • vielleicht noch ein paar weitere infos: openSuse läuft auf einem virtuellen server und darf momentan nur per remote drauf :(

  • die keytable mit dem map.gz sieht etwas komisch aus. trags mal so ein wie vorgeschlagen.

    hab ich versucht, ändert aber leider nichts. aber danke für den hinweis.

  • die keytable mit dem map.gz sieht etwas komisch aus.

    Nee, das paßt scho', lautet auf meinem 11.2 genauso - aber ohne Komma-nochwas dahinter ...



    Wenn ich mir /etc/init.d/kbd so diagonal ansehe, würde ich sagen, daß mein OpenSuSE mit so einem Komma-nochwas-Wert ein "Can not find a keymap for ${KEYTABLE}, Exit." werfen würde. Hast Du beim Booten 'mal die ausführliche Ausgabe mitverfolgt und auf Ungrün geachtet ... ?


    Edit: Was passiert denn bei einem "/etc/init.d/kbd start" (als root)?

  • das neustarten kann ich leider bei remote leider nicht beobachten
    du hast aber recht, bei
    KEYTABLE="de-latin1-nodeadkeys", "de"
    bekomme ich


    Code
    1. /etc/sysconfig/keyboard: line 13: de: command not found
    2. Loading console font lat9w-16.psfu -m trivial G0:loadable done
    3. No keyboard map to load
    4. Loading compose table winkeys shiftctrl latin1.add done
    5. Start Unicode mode done


    bei KEYTABLE="de-latin1-nodeadkeys"
    bekomme ich

    Code
    1. Loading console font lat9w-16.psfu -m trivial G0:loadable done
    2. Loading keymap assuming iso-8859-15 euro
    3. Loading /usr/share/kbd/keymaps/i386/qwertz/de-latin1-nodeadkeys.map.gdone
    4. Loading compose table winkeys shiftctrl latin1.add done
    5. Start Unicode mode


    Nur leider loest es das problem nicht!

  • Nur leider loest es das problem nicht!

    Dann stehen wir also nach wie vor vor der Frage, ob hier eigentlich die Tastatureinstellung des OS (inkl. dem bisher betrachteten Mapping), der GUI oder des Fernzugriffsmechanismus' den Ärger verursacht. :(


    Versuchen wir 'mal, ob wir vielleicht das eigentliche OS und X11 ausgeschlossen bekommen. Kommt bei Dir, nach Korrektur der /etc/sysconfig/keyboard und Reboot, dasselbe 'raus wie bei mir?


    (Nein, auf der tatsächlich angeschlossenen Tastatur sitzt die Taste mit "numbersign" (#) und Apostroph nicht links neben dem Y, sondern am rechten Ende der Reihe darüber. Die direkt aufeinanderfolgenden Keycodes 51 und 52 haben sie aber trotzdem, xev bestätigt es. :rolleyes: )

  • tut mir leid vielleicht stell ich mich bloed aber bei mir kommt da gar nichts
    und sorry wegen der fehleden satzzeichen aber jetzt geht auch mein nummernblock nicht mehr auf dem vor der umstellung noch ein paar zeichen und zahlen funktioniert haben :)


    Code
    1. # dumpkeys | grep '^keycode' | grep -i -A 1 -B 1 ' [yz] *$'
    2. #
  • neue informationen.


    ich konnte jetzt endlich mal direkt auf den server drauf ohne remote verbindung und da stimmt die tastatur... also liegts wohl irgendwie an der verbindungsart. da kann man aber nix von wegen tastatur rumschrauben..

  • Von was sprechen wir denn da? RDP? VNC? Konsole im VMware-Admin-Tool?


    Schonmal sicherheitshalber erwähnt: Die druckbaren Zeichen des 7-Bit-ASCII-Satzes kann man notfalls mit der Maus aus einem "man ascii" heraus-copy-pasten und wenn's noch Sonderzeichen obendrauf braucht, kann man sich sowas wie

    Code
    1. awk 'END { for (i=128;i<256;i++) printf "\0%c ",i; }' < /dev/null | iconv -f iso-8859-1 -t utf-8


    zusammenstöpseln ...


  • hab ich dich falsch verstanden oder du mich?


    ich greife ja von einem windows rechner zu. Der Versuch mit vnc ist aber auch wegen einem tastaturproblem gescheitert :)


  • hab ich dich falsch verstanden oder du mich?


    ich greife ja von einem windows rechner zu. Der Versuch mit vnc ist aber auch wegen einem tastaturproblem gescheitert :)


    edit meint die pisa studio hat bei mir zugeschlagen und ich sollte lesen lernen.


    habe dich falsch verstanden ^^


    hast du es schon von einer anderen maschine versucht?

  • ja hab ich, aber mit lauter windows xp rechnern! mal schaun..vielleicht fällt mir noch was ein!

  • offtopic frage - wieso greift man via gui auf einen linux server zu, wenn man in die shell moechte? die sache rennt doch sicher selbst encrypted, da wuerde ein ssh tunnel doch auch reichen ;-)