vSphere does not return Vm data


(Marius Brenner) #1

Hello everybody,

I’ve been trying for hours to solve the following problem.
I created all my VMs and ESX servers in check_mk version Raw 1.5.0p9.
Then I created the rule that connects check_mk to vSphere. I also get all the information I want to get from the ESX servers (memory, CPU, etc.). But if I want this information from the individual VM’s I do not get it.
The hostnames are also the same as the names in vSphere, I read the instructions on the Check_mk page several times and checked everything.
I have nowhere installed the Check_mk client (I do not have to if I understand it correctly).
The read-only user has been credited to vSphere and all ESX servers.
I hope the screenshots help

I hope you can Help me Thanks!

(Philipp Näther) #2

You didn’t check “retrieve information about virtual machines”.

(Marius Brenner) #3

Thanks for the tip, I have found the error and must specify the hosts with domain extension. Now I want to regulate this over Piggyback. But if I enter everything it does not work and I get the following error
Check_MK Discovery CRIT - no unmonitored services found, no vanished services found, [special_vsphere] Agent exited with code 1: Unable to get data from Web API
But if I set up the hosts without piggyback, it works.
More detailed information on the screenshots

(Philipp Näther) #4

The hostname translation for piggybacked hosts is not for the esx vcenter or esx hosts. It is used for hosts in your cmk, which are actually VMs on your esx systems, but have a different name in vSphere.

So if your cmk host is named “webserver1” but the VM is called “web-server01” you have to add a translation rule so cmk knows which host the piggybacked data belongs to.

(Marius Brenner) #5

So my is not the way I thought it was possible?
Can I still somehow display the data from host esx4.mydomain.com in Host Idrac-Esx4?

(Philipp Näther) #6

Could you give a detailed setup on your esx environment please? Like, do you have a vcenter and which esx hosts does it manage and what are the cmk host names for those servers?
Because I do not completely understand what you are trying to achieve.

(Marius Brenner) #7

Hey, I have found a workaround for this solution but I noticed that I get the following error for each guest system (screenshot) and have no approaches.

(Philipp Näther) #8

You have the wrong agent type in the host settings. If your VM does not have the check_mk_agent installed, you have to set agent type to “no agent”.

(Marius Brenner) #9

Ah okay thanks a lot for the help :smiley: