Upgrade error icinga2

ubuntu

(DataSam) #1

Fehler beim Bearbeiten des Paketes icinga2 (–configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert

Thes System is Ubuntu 14.04, untill yesterday all pakages were up-to-date. Yesterday i did updates and there has not been an icinga update. Today with only the updates totday released it runs in this error. while upgrading it asked me for replace checker.conf, i tried with and without replacing.

What is missing?


(Nicolai) #2

Is there any more verbose error message? Looking at your Ubuntu version, you will might run into this issue:

So better stay with 2.8.4 until the above is fixed.


(DataSam) #3

i am Sorry to say that this System has to run, i had tp play back the snapshot i made before instantly. At th moment there is no time to look for errors. But there was an error found which was with init systems… when will it be fixed for updaters in regular repository?


(DataSam) #4

…when will it be fixed for updaters in regular repository?


#5

What do you mean with regular repository? The linked issue is fixed in version 2.9.1 which is available through the official repository at https://packages.icinga.com/.


(DataSam) #6

i meant through regular ubuntu repository… sry, i was ill long time, i will take a look at it next week.


(Michael Friedrich) #7

We as Icinga don’t maintain Ubuntu upstream nor PPA repositories. The versions we release and deploy are available on packages.icinga.com.


(DataSam) #8

yes you are all right, i added the sources as first and did forget. but then i have another problem, because of updating these pakages didnt solve my problem during update, as like before, icinga didnt start after update.


(DataSam) #9

today i was able to solve it, it was a command object which was not in use, whiche causes update to fail.
after deleting this command object update ran fine.

now i have next question, what i saw is that icinga-web2 is limited to 2.4 in ubuntu 14.04. i tried do-release-upgrade in testing machine, which does not work, because of ubuntu changed too much i guess.

so i have to migrate, but then i want to use ubuntu 18.04. Server installation is fine, but icinga installation run straight into error of unsolved dependecies, after adding icinga bionic sources.

What went here wrong?