Update from 1.5 to 1.6 - Cannot connect to 'unix:/omd/sites/Site/tmp/run/live': [Errno 2] No such file or directory

Hey guys

Since I upgraded from 1.5.0p22 to 1.6.0p3 I have the issue with the following error:

Cannot connect to ‘unix:/omd/sites/Site/tmp/run/live’: [Errno 2] No such file or directory

I checked the fstab entry and it’s correct. In the run folder (/opt/omd/sites/Site/tmp/ru) there is a “live-tcp” instead of an live. I checked also the setup for the Site and there’s no Icinga core - only the nagios.

Maybe anyone has some ideas?

Greetz
Ovrld

Hey guys

Tried again with 1.6.0p6 and still the same issue. Under “/omd/sites/site/tmp/run” is just a “live-tcp” and not a “live”.

Sockets and pipes
Nagios’ command pipe : /omd/sites/site/tmp/run/nagios.cmd
Nagios’ check results directory : /omd/sites/site/tmp/nagios/checkresults
Socket of Check_MK’s livestatus module : /omd/sites/site/tmp/run/live

The difference here is, that I use the “Icinga” kernel and it’s changed to Nagios. Before it was:

Nagios’ command pipe : /omd/sites/Monitoring/tmp/run/icinga.cmd

In “omd config site” I have Icinga. Is the Icinga kernel removed?

Any ideas how I can fix this?

Greetz
Ovrld

This issue is usually caused by a former site config with icinga core.
Make sure to set the core to nagios. Restart the site and try to run a cmk -R to restart the core and rewrite the config. cmk -X can be used to check teh config.

1 Like

Thanks you - I verified the same issue. And what do you mean with “rewrite the config”?

Thanks you for your help!

Edit:
Got it - * 7076 FIX: Removed EOL icinga 1 core from Check_MK packages

With cmk 1.6.0x icinga was removed as core because it is EOL.
cmk -R not only restarts the core but also writes the nagios config.

1 Like

Thanks - it worked for me! Thanks! :slight_smile: