Unable to disable the warn/crit for Service

Hy all,

i will disable the warning/critical alert for a montiored windows service (windows update)
but when i set the fields: “update_win_crit, update_win_warn & update_win_reboot” to false or “0” nothing happends.

is there another way to monitor the service without any alert/warning notify ?

btw: i was trying the settings from:
https://www.icinga.com/docs/icinga2/latest/doc/10-icinga-template-library/#update-windows
greetz

Hi,

Just disable the notification on these services or don’t add any notification at all.

the problem is not the email notify…
i doensnt want to see the alert in the dashboard.

Just set warn/crit to false as described in the docs.

this doesnt works… still tested it with false and with “0”. but without any effort.

You will have to create a new CheckCommand for check_update where no arguments are set. There is a PR aiming to redesign the thresholds as well https://github.com/Icinga/icinga2/pull/6480

with these settings (see attached screenshot) its not working…

Looking through the code, this is a bug :frowning:

I already created an issue here. With 2.9.0 and up the thresholds are ignored.

1 Like

so hopefully with the next or one of the next icinga2 updates the error coule be fixed…
thx 4 info