SNMP Switch discovery getting Service discovery failed for this host: Your request timed out after 110 seconds


#1

Hi :slight_smile:
When I try to add an SNMP switch I get this error.
No issues when running snmpwalk -v 1 -c or check_mk -D 10.61.204.11 | head -15 from the server.
But snmpwalk has a VERY long output.
Running latest version of check_mk.

What can I do to extend timeout?
Thanks


(Philipp Näther) #2

WATO -> Host & Service Parameters -> Access To Agents -> SNMP: timing settings for SNMP access


#3

I cannot increase settings for more that 60 sec getting:
“120.0 is too high. The maximum allowed value is 60.”
Still same error


(Philipp Näther) #4

In this case you have to set the service/host_check_timeout value in your core settings. If you are using CMC it is possible via WATO. For nagios (icinga) core you change the value in ~/etc/nagios/nagios.d/tuning.cfg (~/etc/icinga/icinga.d/tuning.cfg).
After doing this, restart the core and adjust the check_interval for your snmp checks to the same value, you set in the previous config.


#5

Changed service_check_timeout=60 from 60 to 120 (hopefully this is the right one to change?)
omd restart
still getting “120.0 is too high. The maximum allowed value is 60.”
and timeout is discovery


(Philipp Näther) #6

Actually I guided you to the “wrong” file. The tunings.cfg should not be edited manually. Instead copy the value you changed in tuning.cfg to the nagios./icinga.cfg file in the parent directory.
Also set the host_check_timeout value to 120.

Instead of this rule use “monitoring configuration -> service checks: normal check interval” and set your host as explicit host and * as service you want the rule to be applied to.


#7

Icinga main configuration file

This file will be read in after the files in icinga.d.

Variables you set here will override settings in those

files. Better do not edit the files in icinga.d but rather

copy variables from there to here. That will save you

trouble when updating your sites to new versions.

service_check_timeout=120
host_check_timeout=120

Did no seem to help…

Also changed normal check interval to two minutes for the specific folder the host is in, this host has thousands of services I cannot specify a specific service.


(Philipp Näther) #8

Does it take more than 60 seconds to do this on command line?


#9

Yes, about 70 seconds much more for other switches around


(Philipp Näther) #10

How long does a snmpbulkwalk take?


#11

About 90 seconds for snmpwalk


(Philipp Näther) #12

Ok. Please run as site user cmk --snmpwalk HOST. This shouldn’t time out, right?


#13

It does not timeout but it takes a few minutes.


(Philipp Näther) #14

Ok, now check if it created the snmpwalk in ~/var/check_mk/snmpwalks/HOST.

If the file is present, go to “WATO -> Access to agents -> SNMP: Simulating SNMP by using a stored SNMP walk” and set this rule for the HOST you previously stored the snmpwalk for.

After applying the rule, run the inventory for the host again and see if it finds the services. Enable the services you want to monitor. Apply the changes so the core restarts and the config files get written. After that you can delete/disable the rule for simulated snmpwalk and see if the host and its services get checked correctly without any timouts.


#15

After creating the rule and going to host services getting the below error:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request *[GET /verint/check_mk/wato.py]
Reason: Error reading from remote server


(Philipp Näther) #16

I tested it as described on my 1.5.0p7 and it worked as expected. Unfortunately I can’t tell what causes your error there. Actually, for me it does not seem to be related to the changes we made based on this thread.

Instead of running the inventory via WATO, try it on the command line cmk -II HOST.


#17

Yes that has to be something I did before trying to solve this, but restoring configuration did not solve this error :frowning:

Anyway cmk -II HOST works with no issues but I am unable to see the services in GUI.


(Philipp Näther) #18

Did you run a cmk -R afterwards?


#19

Sorry no, I’m not familiar with CLI but learning.
Ran is now, still same timeout.


(Philipp Näther) #20

But after cmk -R you see the services now?