[snmp] Cannot fetch system description OID .1.3.6.1.2.1.1.1.0


(Joshua) #1

I am currently on Check_MK Raw or CRE version 1.5.0P11. This issue was still on 1.5.0P9 as well.

For Windows machines with the agent and no SNMP and also Linux with Agent and no SNMP I am getting this CRIT on Check_MK Discovery. I have tried making it postive with the rule but then the discovery starts to time out. I have tried marking with no SNMP and still same issue. I go to WATO and do the save and test and it just shows snmp being timed out with exit code 1. It gets the data from the client.

Here is what I get for Check_MK Service (OK)
OK - [agent] Version: 1.4.0p31, OS: linux, [snmp] Success, execution time 0.1 sec
Here is what I get for Check_MK Discovery (Crit)
CRIT - no unmonitored services found, no vanished services found, [snmp] Cannot fetch system description OID .1.3.6.1.2.1.1.1.0. This might be OK for some bogus devices. In that case please configure the ruleset “Hosts without system description OID” to tell Check_MK not to fetch the system description and system object OIDs.


(Philipp Näther) #2

Could you provide a full screenshot of the WATO property page of an affected host please?


(Joshua) #3


(Joshua) #4


#5

Hi, maybe you could try a service tabula rasa?


(Joshua) #6

I tried doing a refresh and that did not help. This is on all of the windows and linux machines that I am currently monitoring.


(Philipp Näther) #7

Seems like you have some rule enabled that sets snmp as datasource or the snmp setting enabled on a folder that inherited this setting to all hosts/subfolders.


(Joshua) #8

Do you know of a command line way to look at a more verbose of why? I do not have vary many rules set up. I look at WATO and I do not have anything checked. The default is No SNMP. I have also checked it and same results.


This is the one that I kept coming back too, but this is the default. I did not touch this one.


(Joshua) #9

So when i am in command line. I do a “check_mk --list-tag snmp” and it list the network switches that I want to use snmp but it also lists the windows and linux servers that I do not.

When I go to “~/etc/check_mk/conf.d/wato/servers”

and then cat hosts.mk is has the name and this at the end of each of them “|snmp_blank|lan|ms-Windows-Server-2012-R2|ip-v4|ping|cmk-agent|snmp|no-snmp|tcp|ip-v4-only|site:production|prod|wato|/” + FOLDER_PATH + “/”,"

Should it have snmp and no-snmp. I Go up each level and don’t under stand where the snmp is coming from. Is this my problem or is this normal? It also has no-snmp tag.


(Philipp Näther) #10

Hosts that do not serve info over SNMP should not have the “snmp” tag.
CMK doesn’t assign this tag automatically. So as I told you, you somewhere defined a rule or a folder setting that assigns this tag to the hosts.