Problem with the Icinga Module vSphere

Hello everybody,

I tried all day today to get the vsphere module up and running.

Now you are my last hope! :slight_smile:

I did the following:

  1. A read-only user has been created in the VCenter.
  2. The VSphere module downloaded via git
  3. Module activated and a new import source created in the director. I specified guest.ipAddress as the key parameter. I have attached the complete settings.
  4. A new synchronization rule created (settings see appendix)

If I now try to import the VMs, it will only work if I specify “name” in the import source under key parameter. When I try to change the key parameter to quest.ipAddress (or quest.hostName), I get the following error message:

Diese Importquelle schlug bei der letzten Prüfung um 2020-03-24 16:21:35 fehl: No key column “guest.ipAddress” in row 1

In the Syncronisationrule I get following error message:

Diese Synchronisationsregel schlug bei der letzten Prüfung um 2020-03-24 16:22:13 fehl: There is no key column “guest.ipAddress” in this row from “xxxmvcenter2”: {“guest”:{“guestFullName”:“Microsoft Windows Server 2016 (64 Bit)”,“guestId”:“windows9Server64Guest”,“guestState”:“running”,“hostName”:“xxxAV1.xxx.local”,“ipAddress”:“10.xx.xx.100”,“toolsRunningStatus”:“guestToolsRunning”}}

I don’t want use the key parameter “name” because I create the VM Host a few weeks ago in the Icinga2 director.

What do I wrong? Is it possible, that I use a wrong key parameter?

Thanks for your help!

Marco


Hi,

I solved my problem. I renamed the colum “name” with the FQDN and us now the colume name instead of the colum guest.hostName. I think the problem is, that we use a verrry old vsphere version 5.1 :frowning: (I’m new in the company! ;-))

You can see the different in the Preview of the Import Source: