Problem with configure graphite with icinga 2

#1

Hi,

I installed icinga web by description on this page


Everything works correctly in Icinga 2 web GUI. Apache works only on port 443 and letsencrypt is used in my primary vhost for icinga.mydomain.com domain.

I have a problem with running graphite under icinga 2.
I use the information on these websites:


(…)
sudo docker run -d
–name graphite
–restart=always
-p 80:80
-p 2003-2004:2003-2004
-p 2023-2024:2023-2024
-p 8125:8125/udp
-p 8126:8126
-v /data/graphite/configs:/opt/graphite/conf
-v /data/graphite/data:/opt/graphite/storage
-v /data/graphite/statsd:/opt/statsd
graphiteapp/graphite-statsd

The docker image works correctly. I can display the graphite GUI on page h…p: 192.168.10.10.
I do not have any records there ?.Then I go to install the graphite module:

cd /usr/share/icingaweb2/modules/
git clone https://github.com/Icinga/icingaweb2-module-graphite.git graphite
icinga2 feature enable graphite
icinga2 feature enable perfdata
systemctl restart icinga2

sudo nano /etc/icinga2/features-enabled/graphite.conf
library “perfdata”

object GraphiteWriter “graphite” {
host = “192.168.10.10”
port = 2003
enable_send_thresholds = true
}

I turn on the module : IcingaWeb2 GUI > Configuration > Module >Graphite
I configure the module (backend) : h…p: 192.168.10.10 (Save)

I do not have any charts with any plugins (disk,load,etc).
I do not have a choice of dates. There is no graph field to the right.
When I enter the address h…p: 192.168.10.10/render in the field Graphite Web URL (in Backend configuration module graphite) the graph field is shown but empty (The requested URL returned error: 404 Not Found)

What should I do after installing the docker with graphite+nginx and graphite module for Icinga 2 to have graphs

Please help me !
Best wishes.

My configuration:
Icinga 2.6.2
Ubuntu 18.04.1 LTS with 4.15.0-43-generic kernel