Pnp4nagios not showing the graphs per services

pnp

(soumaya) #1

Hello monitoring lovers,

I have installed :

  • icinga2 : version r2.8.4-1
  • icingaweb2 : version 2.5.3
  • director
  • nagvis

My operating system is Ubuntu Xenial 16.04.4 LTS

Everything is working fine.

I installed pnp4nagios version 0.6.26 and I followed the documentation in order to make everything works fine.

So here is the graphs I get from pnp on my icingaweb2:

But my problem is that when I go into Overview -> hosts -> Hostname (e.g monitor) -> services -> service-name (e.g ping4) I don’t find any graphs :frowning:

But I saw on the internet that it is possible to add the graphs on each service.

Maybe I missed some details during the configuration so if anyone has an idea about what I should do to make the graphs appear on “plugin output section” I will be thankfull for your help :slight_smile:

Thank you,
Soumaya


Missing configuration on icingaweb2 to intergrate pnp4nagios graphs
(soumaya) #2

Hello?

Can anybody help with some smart ideas?


(Chris) #3

please show the installed icingaweb2 plugins from the selection
-> system -> about

URL:

http(s)://someurl/icingaweb2/about


(soumaya) #4

Hello,

Here is a screenshot about icingaweb2 plugins


(Michael Friedrich) #5
  • Check for errors in the apache log
  • Enable the debug log level in Icinga Web 2 and check its log too
  • Open your browsers dev console and look for possible errors

(soumaya) #6

I would like to THANK YOU Michael for your answer, you always know where to find the issue

Here is what I found on the icingaweb2 debug log:
`

2018-06-20T18:30:19+02:00 - DEBUG - Hook “Grapher” (Icinga\Module\Pnp\ProvidedHook\Grapher) (Icinga\Module\Pnp\ProvidedHook\Grapher) failed, will be unloaded: Cannot read PNP4Nagios-Web config file “/usr/local/pnp4nagios/config.php”

So here is what I did to fix it:

I modified the file /etc/icingaweb2/modules/pnp/config.ini

and I changed
config_dir = "/usr/local/pnp4nagios"
to
config_dir = "/usr/local/pnp4nagios/etc"

et voila :smiley: