Performance Data gaps

Hello,

i have some issues with performance data in icinga2. As you can see, there are data gaps every 15-20 minutes. The screenshots shows a graph by icinga2 and grafana.


Actually i don’t know where these gaps came from. Is it possible that something in my /etc/carbon/storage-schemas.conf is wrong?
The gaps are different between the devices, so the icinga2 master hardware itsself cant’t be the reason.

edit: the gap between 14:13 and 14:16 was a reboot of the icinga2 master server.

Please verify that the check results where delivered regularly (probably less than two minutes between consecutive checks).

Hello Wollfgang,

for me it seems the check results where delivered correctly.

Only the green box confuses me a little bit.

2018-10-23_11h08_27

Check-Execution-Time: 4,012s (this seems a little bit high to me)
Check-Latency: 0.000576s

Maybe i have to override the Check-Timeout for the hostalive check?

How would you verify the results?
Sorry, I’m new to icinga, coming from good old nagios. :slight_smile:

Thank You.

“consecutive” checks of the same object.
Looking at the graphs I’d guess that there were no checks between 14:04 and 14:06, the same at 14:22/14:24 and 14:39/14:41 resulting in the gap. Try to find if these gaps correlate to messages/missing checks in the log.

Ok thank you. Yes there was a consecutive check, the normal “hostalive” check (using ping) and the auto generated ping4 service check.
I changed the host standard-check to icmp (perfomance is wonderful) but still have the auto-generated ping4 service-check running. Gap problem solved. :+1:

One last question. Where can i disable the automated ping4 check for hosts? i think it’s enough to check if the host is alive via icmp. no further ping service checks necessary for me.

There is an apply rule somewhere for ping4 check that applies to “where host.address” (if i remember correctly) Just remove it.

1 Like

Yes you are right. I saw it yesterday and it works fine.

The file is: /etc/icinga2/conf.d/services.conf and the rules are "apply Service “ping4” and "apply Service “ping6”.
Commented out, the checks are not applied anymore. I was just wondering why i can’t find these apply rules in the icinga director, but that was my own mistake.

Thank you. Everything fine now. :slight_smile: