NSClient++ invalid password


#1

Greetings,

Sorry if this seems to be a newbie question. I m trying to integrate NSClient++ with Icinga2. When I add some windows services they appear in Icinga2 with status “Unknown” and i get the message NSClient - ERROR: Invalid password.

In the nsclient.ini file I have the field password = filled with the password I use to identify against icinga2web.

Some help is much appreciated!

best,

Lyubo


#2

Please note that there are several “password = ...” lines.


#3

Hello Wolfgang,

thanks for your answer. What do you mean by “There are server password lines?”

Here is my ini file:

# If you want to fill this file with all available options run the following command:
#   nscp settings --generate --add-defaults --load-all
# If you want to activate a module and bring in all its options use:
#   nscp settings --activate-module <MODULE NAME> --add-defaults
# For details run: nscp settings --help


; in flight - TODO
[/settings/default]

; Undocumented key
password = ******
; Undocumented key
allowed hosts = 192.168.0.1, 192.168.0.2


; in flight - TODO
[/settings/NRPE/server]

; Undocumented key
ssl options = no-sslv2,no-sslv3

; Undocumented key
verify mode = peer-cert

; Undocumented key
insecure = false


; in flight - TODO
[/modules]

; Undocumented key
CheckExternalScripts = disabled

; Undocumented key
CheckHelpers = disabled

; Undocumented key
CheckEventLog = disabled

; Undocumented key
CheckNSCP = disabled

; Undocumented key
WEBServer = enabled

; Undocumented key
CheckSystem = disabled

; Undocumented key
NSClientServer = enabled

; Undocumented key
NRPEServer = enabled

; CheckWMI - Check status via WMI
CheckWMI = enabled

; CheckDisk - CheckDisk can check various file and disk related things.
CheckDisk = enabled


; Web server - Section for WEB (WEBServer.dll) (check_WEB) protocol options.
[/settings/WEB/server]

; PASSWORD - Password used to authenticate against server parent for this key is found under: /settings/default this is marked as advanced in favor of the parent.
password = **********
; PORT NUMBER - Port to use for WEB server.
port = 8443

best,

Lyubo


#4

Sorry, I overread that :-/.
The password isn’t taken from icinga2web but is a separate password you’ll have to specify in the check commands.


#5

You are entirely correct. It’s not the web password but the password which is here:

; Undocumented key
password = ******
; Undocumented key
allowed hosts = 192.168.0.1, 192.168.0.2

Thanks for your help.

best,

Lyubo