No LDAP and local Login after Update to ICINGAWEB2 2.6.2-1


(Peter) #1

After Update to ICINGAWEB2 2.6.2-1 / ICINGA 2.10.2-1 on my Debian9 system I can’t login over LDAP any more. System tells me, that User ore Password ist wrong.

When I try to login with my local administrator account than I get the following error messages on the screen:

Fatal error: Uncaught ErrorException: Uncaught ErrorException: syntax error, unexpected ‘"’ in Unknown on line 7 in /usr/share/php/Icinga/File/Ini/IniParser.php:265 Stack trace: #0 [internal function]: Icinga\Application\ApplicationBootstrap->Icinga\Application{closure}(2, ‘syntax error, u…’, ‘/usr/share/php/…’, 265, Array) #1 /usr/share/php/Icinga/File/Ini/IniParser.php(265): parse_ini_string(’[Netzwerk]\ntype…’, true, 1) #2 /usr/share/php/Icinga/Application/Config.php(326): Icinga\File\Ini\IniParser::parseIniFile(’/etc/icingaweb2…’) #3 /usr/share/php/Icinga/Application/Config.php(445): Icinga\Application\Config::fromIni(’/etc/icingaweb2…’) #4 /usr/share/php/Icinga/Application/Web.php(239): Icinga\Application\Config::navigation(‘menu-item’) #5 /usr/share/php/Icinga/Web/Navigation/Navigation.php(437): Icinga\Application\Web->getSharedNavigation(‘menu-item’) #6 /usr/share/php/Icinga/Web/Menu.php(21): Icinga\Web\Navigation\Navigation->load(‘menu-item’) #7 zend.view:///usr/share/icingaweb2/application/layouts/scr in /usr/share/icingaweb2/library/vendor/Zend/Controller/Plugin/Broker.php on line 259

I reverted to snapshot before I did service on the system and evrything works fine.

Regards
Peter


(Nicolai) #2

Have a look at your configuration files in /etc/icingaweb2/* as the error message is complaining about something with the INI parser:

grep -R '[Netzwerk]' /etc/icingaweb2

(Peter) #3

Hello Nicolai,

thanks for your feedback. But I checked it again and nothing changed in /etc/icingaweb2/* after my upgrade to icingaweb2 2.6.2-1 (from 2.6.1-1).

I do update every month and until now I had no problems, even with IcingWeb2 updates.

No chanche to login local and via LDAP after upgrade. When I restore the backup erverything works as usual.

Peter


(Carsten Köbke) #4

Did you try to remove the settings from resource.ini and recreate them from the web?
Btw. it would help if you post your resources.ini, groups.ini and authentication.ini, just remove your passwords or any other sensible information.


(Peter) #5

I found the Solution. There where 2 issues.

  1. in /etc/icingaweb2/navigation/menu.ini there was a group statement, which are in 2 lines

groups = “Groupname1
Groupname2”

I put it into one line, separated by comma, and after that I was able to login with my local administrator.

  1. in /etc/icingaweb2/authentication.ini I deleted the filter line from the LDAP resource.

And after that I was able to login via LDAP authentication against my AD again.

But, it worked before under IcingaWeb2 2.6.1-1 and lower.

Peter