No graphs are shown

(Lucas Possamai) #1

There are no graphs shown by Graphite. Even by going directly to a service, or using the “Graphite” menu in Icinga Web. However, I do see some logs in Apache:

192.168.199.9 - - [05/Apr/2019:14:32:25 +1300] "GET /render/metrics/expand?query=icinga2.webserver.services.http_api_ChassisCheck.http.perfdata.time.value HTTP/1.1" 200 1761 "-" "icingaweb2-module-graphite"

Screenshot from 2019-04-05 14-35-58

Icinga version:

icinga2 - The Icinga 2 network monitoring daemon (version: r2.10.3-1)

Copyright (c) 2012-2019 Icinga GmbH (https://icinga.com/)
License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl2.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

System information:
  Platform: Ubuntu
  Platform version: 18.04.2 LTS (Bionic Beaver)
  Kernel: Linux
  Kernel version: 4.15.0-46-generic
  Architecture: x86_64

Build information:
  Compiler: GNU 7.3.0
  Build host: 5746b2511d14

Application information:

General paths:
  Config directory: /etc/icinga2
  Data directory: /var/lib/icinga2
  Log directory: /var/log/icinga2
  Cache directory: /var/cache/icinga2
  Spool directory: /var/spool/icinga2
  Run directory: /run/icinga2

Old paths (deprecated):
  Installation root: /usr
  Sysconf directory: /etc
  Run directory (base): /run
  Local state directory: /var

Internal paths:
  Package data directory: /usr/share/icinga2
  State path: /var/lib/icinga2/icinga2.state
  Modified attributes path: /var/lib/icinga2/modified-attributes.conf
  Objects path: /var/cache/icinga2/icinga2.debug
  Vars path: /var/cache/icinga2/icinga2.vars
  PID path: /run/icinga2/icinga2.pid

PHP Version:

PHP 7.2.15-0ubuntu0.18.04.2 (cli) (built: Mar 22 2019 17:05:14) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.15-0ubuntu0.18.04.2, Copyright (c) 1999-2018, by Zend Technologies

Icinga web 2 version:
2.6.2-1.bionic

Graphite icinga moduled from: https://github.com/Icinga/icingaweb2-module-graphite

Graphite packages:

root@icinga:~# dpkg -l|grep graphite
graphite-api 1.1.3-2
graphite-carbon 1.0.2-1
graphite-web 1.0.2+debian-2

(Ma Bau Me Bad) #2

Hey,

did you enable and configure the Icinga2 graphite feature ?
Please check via ‘icinga2 feature list’

(Lucas Possamai) #3

Hi! Yes I did… It is enabled.

root@icinga:~# icinga2 feature list
Disabled features: compatlog debuglog elasticsearch gelf influxdb livestatus opentsdb statusdata syslog
Enabled features: api checker command graphite ido-pgsql mainlog notification perfdata
#4

Please add a &graph_debug=1 to the URL and show the output that is displayed.

Are the graphs displayed in the graphite-web interface?

(Lucas Possamai) #5

Yes, graphs are displayed in the graphite-web interface.

Output of the debug:

#0 /usr/share/icingaweb2/modules/monitoring/library/Monitoring/DataView/DataView.php(430): Icinga\Module\Monitoring\DataView\DataView->validateFilterColumns(Object(Icinga\Data\Filter\FilterMatch)) #1 /usr/share/php/Icinga/Web/Widget/FilterEditor.php(352): Icinga\Module\Monitoring\DataView\DataView->applyFilter(Object(Icinga\Data\Filter\FilterMatch)) #2 /usr/share/php/Icinga/Web/Controller.php(254): Icinga\Web\Widget\FilterEditor->handleRequest(Object(Icinga\Web\Request)) #3 /usr/share/icingaweb2/modules/graphite/application/controllers/ListController.php(125): Icinga\Web\Controller->setupFilterControl(Object(Icinga\Module\Monitoring\DataView\HostStatus), NULL, NULL, Array) #4 /usr/share/icingaweb2/modules/graphite/application/controllers/ListController.php(49): Icinga\Module\Graphite\Controllers\ListController->filterQuery(Object(Icinga\Module\Monitoring\DataView\HostStatus)) #5 /usr/share/icingaweb2/library/vendor/Zend/Controller/Action.php(507): Icinga\Module\Graphite\Controllers\ListController->hostsAction() #6 /usr/share/php/Icinga/Web/Controller/Dispatcher.php(76): Zend_Controller_Action->dispatch(String) #7 /usr/share/icingaweb2/library/vendor/Zend/Controller/Front.php(937): Icinga\Web\Controller\Dispatcher->dispatch(Object(Icinga\Web\Request), Object(Icinga\Web\Response)) #8 /usr/share/php/Icinga/Application/Web.php(300): Zend_Controller_Front->dispatch(Object(Icinga\Web\Request), Object(Icinga\Web\Response)) #9 /usr/share/php/Icinga/Application/webrouter.php(104): Icinga\Application\Web->dispatch() #10 /usr/share/icingaweb2/public/index.php(4): require_once(String) #11 {main}

#6

This is not what I expected :smiley:
Where did you add the &graph_debug=1 ?

You need to add it to the URL of you icingaweb2 host/service overview page, e.g.
/icingaweb2/monitoring/service/show?host=YOUR-HOST&service=Webinterface&graph_debug=1

(Lucas Possamai) #7

Yup I did added to the URL of a host or service. But nothing happens…

#8

That is very strange.
Normally it should look like this:

How does the backend configuration of your module look like?
Do you have http or https added to the URL?

(Lucas Possamai) #9

Backend configuration is:

http://monitor.example.com:8000/render?

Apache conf file:

<VirtualHost *:8000>

	WSGIDaemonProcess _graphite processes=5 threads=5 display-name='%{GROUP}' inactivity-timeout=120 user=_graphite group=_graphite
	WSGIProcessGroup _graphite
	WSGIImportScript /usr/share/graphite-web/graphite.wsgi process-group=_graphite application-group=%{GLOBAL}
	WSGIScriptAlias / /usr/share/graphite-web/graphite.wsgi

	Alias /static/ /usr/share/graphite-web/static/
	<Location "/static/">
		SetHandler None
	</Location>

	ErrorLog ${APACHE_LOG_DIR}/graphite-web_error.log

	LogLevel warn

	CustomLog ${APACHE_LOG_DIR}/graphite-web_access.log combined

</VirtualHost>

URL debug:

#10

Try setting it to http://monitor.example.com:8000/

1 Like
(Lucas Possamai) #11

LOL

that worked! Graphs are being shown now. Thanks for your help!

#12

:+1: glad we could work it out.

1 Like