NagVis post-install problem - can't access http://nagios-IP/nagvis

nagios-plugins
nagvis

#1

Hello,

I’m currently running Nagios Core version 4.4.1 and I installed NagVis 1.9.8 succesfully.

After the installation when I try to access http://nagios-server-name/nagvis or http://nagios-server-name/nagvis/config.php as the installation says, I get a massive amount of errors. Also, the page URL changes to http://nagios-IP/nagvis/frontend/nagvis-js/index.php?mod=Map&act=view&show=

Here is the error I receive: nagvis_error.txt (47.1 KB)

I tried Googling the issue, and the only solution that worked for people with similar issues and errors was to use chmod -R 777 on the folder /usr/local/nagvis/share, however this didn’t resolve the issue for me.

I have tried installing different versions of Nagvis, for example, the latest stable version 1.9.0 and even older 1.8.X versions. I’ve tried reinstalling the PHP packets and plugins that are required for the NagVis installation. I’ve tried setting different permissions on the NagVis directories.

I’ve been trying to get NagVis to work for about three days now and it’s beginning to come very tiresome. I have not found anyone to have the exact same error when accessing NagVis on the web-browser…


#2

Below is the NagVis installation log and Apache2 error log:

install.log (13.1 KB)
error_log.txt (txt file was too large to be uploaded here)


#3

Looking at the first line I see

The compile directory must be writable, chmod "/usr/local/nagvis/var/tmpl/compile/" to make it writable

so changing /usr/local/nagvis/share doesn’t seem to be correct…


#4

Hi, thanks for helping.

I forgot to mention that I also tried using the command chmod -R 777 /usr/local/nagvis/var/tmpl/compile/

Also tried chmod -R 777 /usr/local/nagvis as during the NagVis installation there are a lot of permissions being se on subfolders of nagvis-directory:


#5

As you didn’t mention your distribution: any chance that SELinux is enabled?


#6

You have saved my week! I’m a bit new to linux, especially CentOS, which I’m running.

I have no idea what SELinux is, but I have now disabled it and NagVis started working!

Thank you very much!