Issues with number of queries


(H. Hamester) #1

Hi,

my graph looks like this:

I think the problem is that the Series A-Z are full. Is there a possibility to realize all queries?
We are using this graph for our Scala-Display


(Carsten Köbke) #2

How does your queries look? For me it looks like you have the same query many times.


(H. Hamester) #3

Yes, for every host one query.

I don’t know how to template the graph


(Carsten Köbke) #4

Hmm you can do a row with a panel for in/out octets and let Grafana Repeat that row for every host. This would need templating for hostnames. so you have a nice dashobard with a graph for each host


(H. Hamester) #5

Can you help me to realize the row? The Problem is that there are different interfaces or more interfaces on one endpoint.


(Carsten Köbke) #6

I will try to do that, but at the moment i cant. Too much work


(H. Hamester) #7

No problem! A sample will help me for future dashboards :slight_smile:


#8

Do something like this for your host variables:

Just play around with it a little and you will get an idea.
For more filters use regex (this tool might be useful: https://regex101.com/)

After setting your desired settings for the variables got to your dashboard --> edit -->

Then you still need to replace your queries with one that uses your host variable.

If anything is still not clear at this point try to go through the official Grafana Documentation.

If that is not enough you can try your luck again here :slight_smile:


(H. Hamester) #9

Thank you for support!
I have tried some possibilities, but I think there are some errors in reasoning… :thinking:

Variable:


· I can choose my Endpoints but there is only one endpoint in the graph.
· I have different interfaces at the endpoint (partly different snmp checks for 32/64bit).

A match with “in_octet” and “out_octet” would solve my problem I guess.
My first thought was to make queries for every different interface (5) with the two octet-values = 10 queries.

Unfortunately I already fail at the output :triumph:


(Carsten Köbke) #10

You need to set the panel to autorepeat in the General tab.Choose you $hostname for repeating and everything should be fine.


(H. Hamester) #11

I set this option but I get only one graph. I need a graph like my first post.
There might be an issue with the different interfaces in the queries. Either too much or too less output.


(H. Hamester) #12

So far - I think i got it and my graph is very pretty!

Thank you so much guys! :slight_smile:

I have a last small adjustment:

Query in Variables: icinga2.wan-versatel--primaer

How can I filter 98wan* from this variable?

I need to exchange the value of scaleToSeconds for this host.


#13

Use a Regex that looks something like this:
^(?!98wan).*$

Not sure if this is what you need exactly and anyhow I would strongly recommend to get a little familiar with regex.

From my own experience I can tell that it is pain in the *** in the first place but it really pays off on the long run.

I need to exchange the value of scaleToSeconds for this host.

Maybe you can tackle this issue by using X- and Y-Axis assignments and using the different datarate (bit/byte) options provided by grafana.


(H. Hamester) #14

Oh thats much better than my solution - (?!.zent).$

Thank you very much!!! :ok_hand: