Installation problem


(Arethusa) #1

Hello, Merry Christmas ^^

Today, I tried on my own server to install: icinga2, icingaweb2, mariadb, influxdb on Centos7

In first time, I have split services, but I have an error, so I try a basic all in one installation, but I have the same problems, I can’t finish the IcingaWeb2 Installation!

So, let me be more precis:

icinga2 version: r2.10.2-1)
Icingaweb2 version: 2.6.2-1.el7
php: php71

Now my history of install

yum update -y
yum install epel-release -y
yum install httpd -y
yum install mariadb mariadb-server -y
yum install https://packages.icinga.com/epel/icinga-rpm-release-7-latest.noarch.rpm
yum install epel-release -y
yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
yum install centos-release-scl
yum install icingaweb2 icingacli
yum install icinga2-ido-mysql -y
yum install icinga2 -y
yum install nagios-plugins-all -y

For mariadb, I do the simplest configuration:

[root@supervision ~]# mysql -u root -p
Enter password:
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 10
Server version: 5.5.60-MariaDB MariaDB Server

Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> CREATE DATABASE icinga;
Query OK, 1 row affected (0.00 sec)

MariaDB [(none)]> GRANT SELECT, INSERT, UPDATE, DELETE, DROP, CREATE VIEW, INDEX, EXECUTE ON icinga.* TO 'icinga'@'localhost' IDENTIFIED BY 'icinga';
Query OK, 0 rows affected (0.00 sec)

MariaDB [(none)]> FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.01 sec)

MariaDB [(none)]> EXIT;
Bye

And:

[root@supervision ~]# mysql -u root -p icinga < /usr/share/icinga2-ido-mysql/schema/mysql.sql

I configure idomysql

[root@supervision ~]# cat /etc/icinga2/features-enabled/ido-mysql.conf
/**
 * The IdoMysqlConnection type implements MySQL support
 * for DB IDO.
 */

object IdoMysqlConnection "ido-mysql" {
  user = "icinga"
  password = "icinga"
  host = "localhost"
  database = "icinga"
}

And of course: it’s enabled:

[root@supervision ~]# icinga2 feature list | grep Enabled
Enabled features: checker command ido-mysql influxdb mainlog notification 

So now the problems:

Why I have conflict? I never see this message before.

That say "successful, but “there is currently no instance writing to the IDO” Of course, it’s not finish!

I don’t understand the problem, maybe I will try with oldest version.

Thank you, have a good holiday!


#2

As shown in the first orange message block it is highly recommended not to mix database schemas of Icinga and IcingaWeb (which you seem to have done as the database name for icingaweb_db is ‘icinga’).


(Arethusa) #3

Hello,

Thank you for answer.

I had username problem with my database on MariaDB. That was my fault.

Thank you.


(Allen Efienokwu) #4

Hello, I have had issues like this countless number of times building icinga2 web.
Your Database Name for Icinga and Icingaweb2 are the same, so you have to innovate here.

For icinga Database Name = icinga_db
For icingaweb2 Database Name = icingaweb_db

That should work, ‘cause the names you have now are conflicting. Let me know how it goes. Happy icinga!

  • Allen E.