Install x509 Module

x509
ipl
reactbundle

(Nigel) #1

I would like to install the x 509 module. in dependencies I need the module ipi and reactbundle. When installing the two modules, I do not understand how the following works:

Add a new dependency
composer require author / library: version
Create a new release
./bin/make-release.sh
E.G.
./bin/make-release.sh 0.1.0

when running: composer require author / library: version
I get the message:

[UnexpectedValueException]
Could not parse version constraint author: invalid version string “author”

which version must be specified here?
The description says:

HINT: Do not install the GIT master, it will not work!

about Tarball installation I have z. b. downloaded from reactbundle version 0.4.1.

Even if I give this version I get an error:

/ usr / share / icingaweb2 / modules / reactbundle # composer require author / library: 0.4.1
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.