Ignoring virtual interfaces


#1

Hi,
how can I ignore the virtual interfaces created by docker (eg. [veth3697768]) for all hosts? I created a rule, but it did not work …

Greetings
Thuranga


(fork) #2

Go to:
-> WATO -> Host and Service Parameters -> Disabled Services -> Create Rule

Select Service option. Specify explicit value. Enter “veth” and “Interface veth”

Save and Apply


#3

I did it this way. But it doesn’t work…

Here ist the part of the generated code in rules.mk:

checkgroup_parameters.setdefault('filesystem', [])

checkgroup_parameters['filesystem'] = [
  ( {}, [], ALL_HOSTS, [u'!Filesystem /data/docker/.*'] + ALL_SERVICES, {'description': u'Exclude Docker filesystems'} ),
  ( {}, [], ALL_HOSTS, ALL_SERVICES, {} ),
] + checkgroup_parameters['filesystem']


checkgroup_parameters.setdefault('if', [])

checkgroup_parameters['if'] = [
  ( {}, [], ALL_HOSTS, [u'!Interface veth.*'] + ALL_SERVICES, {'description': u'Exclude Docker network interfaces'} ),
] + checkgroup_parameters['if']

(fork) #4

I’m sorry, my description was not 100% correct:

-> WATO -> Host and Service Parameters -> Monitoring Configuration -> Disabled Services -> Create Rule

Your configuration ist different from mine. At my site it looks like:

ignored_services = [
   ( [], ALL_HOSTS, [u'veth',  u'Interface veth', ...

#5

Great! Now it works! :grinning::+1:

Thanks!!!