Icingaweb2 and HA_Setup with 2 Master Server didn't work

ha
#1

referring to this thread Icingaweb2 (icinga2) Monitoring Backend is not running

I was hoping that the problem was fixed with a new “setup”, but that is not the case.

Starting point is now:
2 master servers, both accessing the same -external- mysql database server (ido_mysql, icinagweb2, etc).
ha is on for the ido module.

If the Icinga2 instance is running on both servers, the display will change to “red” and no current status will be displayed. Only when I stop the Icinga instance on the second master server (the server was initially satellite) does it work. In the descriptions, I find no special things for icingaweb2.

The goal is to use Icingaweb2 in this setup as a normal administrative tool (Display, Administration inc. Director). The resources (ido, icingaweb2, director) of the respective Icingaweb2 installation all point to the same database and access is also possible.

I assume that the monitoring status is read from the database icinga2 (ie what is written about ido_mysql)? Whats the failure?
Am I the only one with such a setup?

Thanks and greetings for your ideas …
josh

Icinga2 HA-setup import into director
(Marcel Fliegel) #2

Hey Josh,

no you are not alone with this setup. :smiley:

Can you tell us how you configured the second master instance and did you use the official distributed monitoring documentation - High-Availability Master with Clients ? Did the signing process of the second master run without any problems?

It would be great if you could show us the current ‘zones.conf’ of booth master nodes, so that we can understand if your master nodes are in the same master-zone and both act as masters.


Maybe it’ll help you to throw a look into the debug log. You can activate it via Icinga2 CLI:

icinga2 feature enable debuglog

After enabling the feature you must restart the icinga2 service. The debug log is stored in the log directory of icinga2 under the name ‘debug.log’.

#3

Hello Marcel
Thx for your reply.

Now it actually seems to work. I checked all configurations again and had a missing character for a DB password on a server. Now the whole thing has been going on for some time.

The next step is to have this config in the director to assign the objects to the correct zone.
At the moment I can not get the master zone into the director, but without it I can not create any objects without the verification failing.
How can I import the contents of zones.conf into Director?

My Zones.conf:

/* * Generated by Icinga 2 node setup commands

  • on 2019-08-01 15:39:48 +0200
    */
    object Endpoint “master1” {
    host = “master1.domain.com
    port = “5665”
    }
    object Endpoint “master2” {
    host = “master2.domain.com
    port = “5665”
    }
    object Zone “master” {
    endpoints = [ “master1.domain.com”, “master2.domain.com” ]
    }
    object Zone “global-templates” {
    global = true
    }
    object Zone “director-global” {
    global = true
    }
    object Zone “linux-commands” {
    global = true
    }
    object Zone “windows-commands” {
    global = true
    }

Thx for your support…:smiley:

Josh

(Marcel Fliegel) #4

Hey Josh,

sorry for late reply. I am glad that it works now.
I do not manage my clients through the director, so I’m the wrong contact person here.

But I think in the Director category you will surely find someone who can help you with this.

I wish you success.

#5

Thx Marcel.
The Director Config works now too.

1 Like