Grafana : request-URI Too Long(414)


(Arethusa) #1

Hello,

I use Grafana with influxdb / Icinga2 / icingaweb2 on apache server.

That works good, but I have a litle probleme.

I have 33 hosts per graph, so the first probleme is the numerotation, be cause after “Z” (so after the host 26) I don’t have numerotation, is it possible to have “numbers” insteed of “letters” ?

the other probleme is after 32 hosts I have an error on graph : "Network Error: request-URI Too Long(414), but before 32 it’s ok.

Thank you.


(Carsten Köbke) #2

You should use dedicated dashboards and put the hostnames into your query.


(Arethusa) #3

Hello,

I have the hostnames on “Alias by”, it’s not really a problem…

The main problem is the limitation, for example, on a graph called “CPU Usage in %” I have 33 servers, but after 32, I have “Network Error: request-URI Too Long(414)”.

And I have another Dashboard with 25 hosts (other vlan).

I can split the dashboard with 33 host, but that will be not very comfortable to use.

Thank you for your advisement.


(Carsten Köbke) #4

Can you explain a bit better how you call them (url manualy created, dynamic).
Or do you use the Grafana Mofule for Icingaweb2 ?


(Arethusa) #5

On the picture one, you have the bug when all hosts are active, on the red point on top left : “Network Error: request-URI Too Long(414)”, And you have a description of my graph.

On the picture two, if I disable one host (the A for example) the graph is back.

On picture three, you have a big zoom out of my all hosts, like you can see, after Z i don’t have numeration.

Thank you


(Carsten Köbke) #6

you should try to use a regex in your url to use it in the query like

hostname =~ /Server-MAIL*/

and not put every host into the url.


(Arethusa) #7

Hello, I have try to add LimitRequestLine 99999 on etc/httpd/conf/httpd.conf on the first line.

That looks works for the moment.

Thank you.