Grafana module - repeating panels problem


(Craig) #1

Hi all

I am having some difficulty with repeating panels, although that said, I am not sure if it should work the way I expect it to.

I collect disk utilisation using ssh and place that data in InfluxDB. I have a working Grafana dashboard set up that generates a panel for each mount point automatically (I used auto-repeat-disk.json as a template)

If I look under the services of a host, I only see panel 1. Should I be seeing all of the panels one below the other for as many as exist in the Grafana dashboard?

I see reference to a configuration options ‘repeatable’ and ‘nmetrics’, however they don’t seem to be available in the module configuration in icingaweb. Must I add it manually to the ini file?

Craig


(Carsten Köbke) #2

Hi Craig,

this options are available under the graph configuration. here you can configure the dashboard that will be used.
In you case you should mark it repeatable and how many metrics are there in each Grafana panel. If you dashboard creates a panel for each mountpoint/filesystem you should set this to 1.

Best regards,
Carsten


#3

I had the same problem recently but upgrading to the latest version (1.1.10) solved this issue.

You can find everything here:
https://github.com/Mikesch-mp/icingaweb2-module-grafana/releases

How to do an upgrade is well documented here:
https://github.com/Mikesch-mp/icingaweb2-module-grafana/blob/master/doc/05-update.md

I recommend using tarball since that worked for me

For enabling repeating Panels insinde Icingaweb2 to go to --> Configuration --> Grafana Graphs --> “YourGraphHere” --> Repeating Panels --> Yes

As @Carsten already mentioned make sure that your Grafana Dashboards are repeatable


(Craig) #4

Ah thank you!

Apologies for the late reply.

I just updated to 1.1.10 and the Repeating Panels option became available.
Works perfectly.