Failed connect to icinga.nppl.yo:8003; Connection refused


(Matt Herzog) #1

When I click on Graphite > Hosts (or) Services I see
Failed connect to icinga.nppl.yo:8003; Connection refused

But at least the php is being rendered properly. I’ll post a screen shot if need be.
I just can’t remember where I saw I needed to have graphite (carbon?) listening on 8003.

/etc/graphite-web/local_settings.py

DATABASES = {
    'default': {
        'NAME': 'graphite',
        'ENGINE': 'django.db.backends.mysql',
        'USER': 'graphite',
        'PASSWORD': 'obviously.not.real',
        'HOST': 'localhost',
        'PORT': '3306'
    }
}
netstat -tulpn
tcp        0      0 127.0.0.1:9000          0.0.0.0:*               LISTEN      802/php-fpm: master 
tcp        0      0 0.0.0.0:3306            0.0.0.0:*               LISTEN      1145/mysqld         
tcp        0      0 0.0.0.0:111              0.0.0.0:*                LISTEN      1/systemd           
tcp        0      0 0.0.0.0:2003            0.0.0.0:*               LISTEN      19900/python2       
tcp        0      0 0.0.0.0:2004            0.0.0.0:*               LISTEN      19900/python2       
tcp        0      0 0.0.0.0:22              0.0.0.0:*                 LISTEN      800/sshd            
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1170/master         
tcp        0      0 0.0.0.0:7002            0.0.0.0:*               LISTEN      19900/python2       
tcp        0      0 0.0.0.0:5665            0.0.0.0:*               LISTEN      2050/icinga2        
tcp        0      0 127.0.0.1:161           0.0.0.0:*               LISTEN      801/snmpd           
tcp6       0      0 :::111                  :::*                    LISTEN      1/systemd           
tcp6       0      0 :::80                   :::*                    LISTEN      20742/httpd         
tcp6       0      0 :::22                   :::*                    LISTEN      800/sshd            
tcp6       0      0 ::1:25                  :::*                    LISTEN      1170/master         
udp        0      0 0.0.0.0:41552           0.0.0.0:*                           801/snmpd           
udp        0      0 0.0.0.0:161             0.0.0.0:*                           801/snmpd           
udp        0      0 0.0.0.0:43745           0.0.0.0:*                           801/snmpd

(Matt Herzog) #2

Versions:
icingaweb2-vendor-lessphp-2.5.1-1.el7.icinga.noarch
icinga2-common-2.8.1-1.el7.icinga.x86_64
icingaweb2-vendor-zf1-2.5.1-1.el7.icinga.noarch
icinga-rpm-release-7-2.el7.centos.noarch
vim-icinga2-2.8.1-1.el7.icinga.x86_64
icingacli-2.5.1-1.el7.icinga.noarch
icingaweb2-vendor-JShrink-2.5.1-1.el7.icinga.noarch
icingaweb2-vendor-HTMLPurifier-2.5.1-1.el7.icinga.noarch
icinga2-bin-2.8.1-1.el7.icinga.x86_64
php-Icinga-2.5.1-1.el7.icinga.noarch
icinga2-libs-2.8.1-1.el7.icinga.x86_64
icingaweb2-common-2.5.1-1.el7.icinga.noarch
icingaweb2-vendor-Parsedown-2.5.1-1.el7.icinga.noarch
icinga2-ido-mysql-2.8.1-1.el7.icinga.x86_64
icingaweb2-vendor-dompdf-2.5.1-1.el7.icinga.noarch
icingaweb2-2.5.1-1.el7.icinga.noarch
icinga2-2.8.1-1.el7.icinga.x86_64


(Matt Herzog) #3

Do I need to enable the perfdata feature?


(Matt Herzog) #4

Is it generally considered good practice to get Graphite working before trying to connect it to Icingaweb2?


(Michael Friedrich) #5

Yes, sure. It enables you to debug just one end, not two or more in a mixed where you’ll eat your keyboard at some point.

You’ve seen the different port inside the Vagrant box, this puts all in one and has the problem that Graphite only works on a VHost without a sub-directory. Common scenarios use a dedicated server for Graphite, and there you just put Graphite-Web onto 80/443.