Event Console Error: Failed: Cannot send command to unconfigured site


(fork) #1

When I want to activate changes to the event console I get the following error:

Failed "cannot send command to unconfigured site MYSITE"

Google told me that there are some others who had the same problem. A solution was not listed.

Digging into the site directory via shell i got additional informations in:

$MYSITEDIR/tmp/check_mk/wato/activation/55c81559-2686-4dc6-aa39-2ba6b1344508/site_local-site.mk

{'_expected_duration': 10.0,
 '_phase': 'done',
 '_pid': 11422,
 '_site_id': 'local-site',
 '_state': 'error',
 '_status_details': "Started at: 12:50:06. Finished at: 12:50:06.<br>Failed: Cannot send command to unconfigured site 'MYSITENAME'",
 '_status_text': 'Failed',
 '_time_ended': 1539255006.960704,
 '_time_started': 1539255006.921553,
 '_time_updated': 1539255006.960704,
 '_warnings': []}

That seemed to me that the error was the mismatch between sitename “local-site” and my actual sitename “MYSITENAME”.

So, I searched for the configuration file in which MYSITENAME or “local-site” is defined and found ./check_mk/multisite.d/sites.mk. There I replaced local-site with MYSITENAME.

After that I’m able to activate new changes in the event console.

The instance is running for some years now and had been upgraded multiple times. I assume at the latest upgrade(to 1.4.x) in multisite it is no longer allowed to have a local site be named local-site(as it was the default configuration at installation time) but instead it must be named exactly like the actual sitename. When I tried to create a new local-connected Site there was an error message stating this too.


#2

Hi @fork, nice that you solve your problem.
Can you post your solution here of course if you dont mind.

for other users it would be really helpful :slight_smile :slight_smile:

Regards,
Neeloj


(fork) #3

The post already contains the solution.

For short:

change the sitename in $YOURSITENAME/etc/check_mk/multisite.d/sites.mk

change this text: local-site
change text to: $YOURSITENAME

(…and always have a good backup at hand!)


(Vladislav) #5

Hello!

Thanks for the given solution, just faced the same issue.
Did you faced any troubles after changing the site name? Is all configuration/rules/distributed connections saved? And how you changed hosts configuration? (because in each host you need to specify at which node it is monitored)

Thank you in advance!


(fork) #6

Hi Vladislav,

I did not face any trouble after the change. I did not have to make further changes. (I have only a single monitoring site).

Regards,
Tobias


(Vladislav) #7

Thank you for the answer!
I tried to change it on the test installation and noticed that hosts was duplicated (same name, but other config: “Monitored on site”, because node changed the name).