Cpu load average

(Tobias Grossmann) #1

Hi,

since one week I have a high load average although i haven’t add host or services.
I restartet the VM, but nothing changed.

Anyone out here who has a hint for?

Regards, Tobi

SNAG-0007

#2

hi tobi,

have you tried recompiling the core?

btw: you have posted this twice.

(Tobias Grossmann) #3

Hi ultimo,

i tried cmk -C, but nothing changed.
Or what do you mean?

#4

I mean cmk -R this will recompile and restart the Nagios Core. If this won’t work you can try switching the core between Nagios and Icinga.
Were you able to find out what happened at the point the load went up? Did you add new hosts / services? applied some new rules?

(Tobias Grossmann) #5

Hi ultimo,

cmk -R is made on every rebgot i think. Maybe i change from cre to cee, that will be the best way.
:wink:

thanx for you help

(Philipp Näther) #6

I don’t think so. Such increasing CPU load doesn’t happen out of the blue. There must be a reason.

Go to WATO, click on “pending changes / no pending changes” and then “Audit Log”. Specify the date where the load went up (03.05.2019) and see the changes that have been made.

Also determine the correct time on that day where the load went up.

(Tobias Grossmann) #7

In the audit-log there are no changes on this specific date. :frowning: Maybe there was something changed at our firewall, network or hyperv, i will ask my network-colleagues. i wonder why the precompiled checks are now so “cpu hungry”.

(Philipp Näther) #8

High load does not mean the checks are cpu hungry. High load means they somehow need too long to be executed and so add at top of each other what results in high cpu usage.
Please check with iotop if you can find any anomaly on disk io operations.

(Tobias Grossmann) #9

Hi,

i deleted the precompiled checks, made a cmk -D an restartet the VM, now the CPU is in normal state. very “funny”.