Could not expand all macros!

#1

Good morning,

I have Thruk 2.26-2 with Nagios 4.4.3.
When I go in detail of hosts/services I have the error in the Expanded Command.

I have defined the resource_file with $USER1$=/usr/local/nagios/libexec and expand_user_macros=ALL (as defualt).

Do you have any ideas? Do you need some logs?

Appreciate andy indications.

Thanks
regards
Antonio

#2

Please show the definition itself in the configuration file.

#3

thruk.conf (40.2 KB)
thruk_local.conf (825 Bytes)

Hi Wolfang,

I just uploaded the configurations.
Many thaks for the support.
Best regards
Antonio

#4

Please show a host/service definition using $USER1$ and the relevant resource.cfg entry, not the configuration files.

#5

Hi Wolfang,
sorry for misunderstanding. I upload the commands.cfg and resource.cfg.

many thanks for the support.
Best regards
Antonio
commands.cfg.txt (6.3 KB)
resource.cfg.txt (1.3 KB)

#6

The name and location for the file is /tmp/resource.cfg?
I don’t know if it makes any difference but I’d move the entry to the <options> section.

#7

Hi Wolfang,
/tmp/resouce.cfg is the location in thruk server.
In nagios server the location of the same resource.cfg is /usr/local/nagios/etc.
Becuse there isn’t any shared files-systems between the two servers.

Thanks.
Antonio

#8

Other than the entry at the top I don’t see any reason so far.

#9

Excuse me Wolfang,
which entry you mean?

#10

I’d move the resource_file entry like this:

expand_user_macros = ALL

<Component Thruk::Backend>
    <peer>
        name    = Lot_5
        id      = 7215e
        type    = livestatus
        <options>
            peer          = amssv0110:6557
            resource_file = /tmp/resource.cfg
#            resource_file = /usr/local/nagios/etc/resource.cfg
        </options>
        <configtool>
            core_conf      = /usr/local/nagios/etc/nagios.cfg
            obj_check_cmd  = /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg
            obj_reload_cmd = /etc/init.d/nagios reload
        </configtool>

    </peer>
</Component>
#11

Hi Wolfang,

I do the change but unfortunatly has not fixed.

I have not any ideas

Thank
antonio