Check_mk with jolokia error

Hi, I have a problem with joolokia in check_mk on my vm client, jolokia works fine from web explorer, but in check_mk I can’t config it.

I’m not understand the config file, i supposed all it’s fine,

# Settings for authentication
protocol = "http"
server   = "192.168.10.134"
port    = 22000
user     = "admin"
password = "******"
# mode     = "digest"
# use "basic_preemptive" if server responds with 403 forbidden even
# though user/password are correct
# mode     = "basic_preemptive"
suburi   = "jolokia-war-1.60"
instance = None

# Configuration for multiple instances. Not-specified
# values will be taken from the upper settings
#instances = [
#   {
#       "port"     : 22000
#       "instance" : "FOO",
#   },
#   {
#       "protocol" : "http"
#       "server"   : "192.168.10.134"
#       "port"     : 22000
#        "instance" : "BAR",
#        "user"     : "harri",
#        "password" : "hirsch",
#   }
#]

When execute the command via linux throw this:

# /usr/lib/check_mk_agent/plugins/mk_jolokia --verbose
DEBUG: Fetching: http://192.168.10.134:22000/jolokia-war-1.6.0/
ERROR: HTTP Error 401: Unauthorized
ERROR: Invalid json code (expected string or buffer)
       Response []
<<<jolokia_info>>>
22000 ERROR
<<<jolokia_metrics>>>
22000 ERROR

Any idea?

Please take a look at the FAQ and reformat your posting as it enhances readability.

1 Like