Check_MK Apache

#1

hi all,

why my site is only available when I write check_mk/ at the end of the url?
that mean: https://xyz.de/mysite <— ist not available
https://xyz.de/mysite/check_mk/ <— the slash is important and this will work!

does anyone why?

Regards
Neeloj

(Philipp Näther) #2

In the apache config (the omd.conf) should be a rewrite rule that redirects from /site to /site/check_mk.

Check if this is present.

1 Like
#3

thanks for your answer @TheLucKy
yes its present…

RewriteRule ^/mysite/?$ /mysite/check_mk/ [R=302,L]

(Philipp Näther) #4

Did you make any changes in the past related to the apache?
Does it work if you use http?
Login as site user and run apachectl -M | grep rewrite to see if the rewrite module is currently loaded.

1 Like
#5

No I didnot touch the file…

yes it works with port 80

OMD[mysite]:~$ apachectl -M | grep rewrite
AH00526: Syntax error on line 34 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
SSLCertificateFile: file ‘/etc/letsencrypt/live/xyz.de/fullchain.pem’ does not exist or is empty

there is an error!

#6

the file exist and is not empty!

(Philipp Näther) #7

Check if this can help you: https://community.letsencrypt.org/t/apache-sslcertificatefile-error-does-not-exist-or-is-empty/14995/10

1 Like
#8

from
drwx------ 4 root root 4096 Feb 11 11:51 archive/
to
chmod -R 0755
drwxr-xr-x 3 root root 4096 Jan 10 2019 archive/

apachectl configtest
Syntax OK
sudo service apache2 reload
and login as site user I get same error…

#9

solved, for me was live folder!

Strange but it works :slight_smile: I get now as site user rewrite_module (shared)

OMD[mysite]:~$ apachectl -M | grep rewrite
rewrite_module (shared)

but the omd.conf still not working… I want write until mysite and then ENTER … Now I have to write check_mk/

(Philipp Näther) #10

You wrote it works for http. Check the rewrite rule for correct syntax to rewrite https.

1 Like
#11

That’s right, but this is the only rewrite rule for https:
RewriteRule ^/mysite/?$ /mysite/check_mk/ [R=302,L]

And if I change it to :

RewriteRule ^/mysite/?$ /mysite/ [R=302,L]

And restart omd and Apache nothing changes, it’s the same! I don’t know if there is also another place to change the rule!!!

It’s very strange!

Thanks for your help