Check Command Output not completely in Icinga 2

#1

Hi there,

I have a problem with modifiying the check disk command. I’m trying to exclude a specified partition (with the argument -x or because this didn’t worked I also tried it with -i) and this seems to work. But when I do this, Icinga 2 only gets the information of the first 4 partitions found and doesn’t shows any further partition.
If I execute the check command shown by the “Inspect” option in Icingaweb 2 on my Icinga 2 node with all arguments and as Icinga-User I get the whole output.

Has anybody had the same problem or an idea what could be the problem?

(Aflatto) #2

Hi Alicia

I have not encountered such behavior in the past.
What version of IcingaWeb2 , Icinga2 and Director are you using ?

#3

Hi,

versions are:
Icinga2: r2.10.5-1
IcingaWeb2: 2.6.3
Director: 1.6.2

I’m not sure if it would be helpful to show the output in this topic?

(Aflatto) #4

More data is always a good thing when trying to debug an issue

#5

Well,
here we have the Plugin-Output from IcingaWeb2:

The executed Command is (shown at “Inspect”) is:
‘/usr/lib/nagios/plugins/check_disk’ ‘-c’ ‘10%’ ‘-w’ ‘20%’ ‘-X’ ‘none’ ‘-X’ ‘tmpfs’ ‘-X’ ‘sysfs’ ‘-X’ ‘proc’ ‘-X’ ‘configfs’ ‘-X’ ‘devtmpfs’ ‘-X’ ‘devfs’ ‘-X’ ‘mtmfs’ ‘-X’ ‘tracefs’ ‘-X’ ‘cgroup’ ‘-X’ ‘fuse.gvfsd-fuse’ ‘-X’ ‘fuse.gvfs-fuse-daemon’ ‘-X’ ‘fdescfs’ ‘-X’ ‘overlay’ ‘-X’ ‘nsfs’ ‘-X’ ‘squashfs’ ‘-m’ ‘-R’ ‘/’ ‘-i’ ‘^/boot’

Using this command local on the host:

‘/usr/lib/nagios/plugins/check_disk’ ‘-c’ ‘10%’ ‘-w’ ‘20%’ ‘-X’ ‘none’ ‘-X’ ‘tmpfs’ ‘-X’ ‘sysfs’ ‘-X’ ‘proc’ ‘-X’ ‘configfs’ ‘-X’ ‘devtmpfs’ ‘-X’ ‘devfs’ ‘-X’ ‘mtmfs’ ‘-X’ ‘tracefs’ ‘-X’ ‘cgroup’ ‘-X’ ‘fuse.gvfsd-fuse’ ‘-X’ ‘fuse.gvfs-fuse-daemon’ ‘-X’ ‘fdescfs’ ‘-X’ ‘overlay’ ‘-X’ ‘nsfs’ ‘-X’ ‘squashfs’ ‘-m’ ‘-R’ ‘/’ ‘-i’ ‘^/boot’
DISK OK - free space: / 6606 MB (66% inode=98%); /opt 4380 MB (85% inode=99%); /home 5049 MB (99% inode=99%); /tmp 2002 MB (98% inode=99%); /var/log 10171 MB (99% inode=99%); /sppedtest 32673 MB (79% inode=99%);| /=3322MB;7942;8935;0;9928 /opt=728MB;4086;4597;0;5108 /home=49MB;4079;4589;0;5099 /tmp=34MB;1628;1832;0;2036 /var/log=57MB;8182;9205;0;10228 /blabla=8265MB;32750;36844;0;40938

(Aflatto) #6

So the data missing from the output on the IcingaWeb2 is this :

Anything after the ‘|’ will not show as it is perfdata and is parsed to other functions.

The fact that ones shown are not matching the CLI output maybe related the way the command is defined in the director, but the fact that it is not showing all could be a but’ as the output length is limited to 65k chars.

#7

I can’t imagen, that it is about the limitation. If I use the standard “disk” command, I get all partitions, including the /boot partition:

‘/usr/lib//nagios/plugins//check_disk’ ‘-c’ ‘10%’ ‘-w’ ‘20%’ ‘-X’ ‘none’ ‘-X’ ‘tmpfs’ ‘-X’ ‘sysfs’ ‘-X’ ‘proc’ ‘-X’ ‘configfs’ ‘-X’ ‘devtmpfs’ ‘-X’ ‘devfs’ ‘-X’ ‘mtmfs’ ‘-X’ ‘tracefs’ ‘-X’ ‘cgroup’ ‘-X’ ‘fuse.gvfsd-fuse’ ‘-X’ ‘fuse.gvfs-fuse-daemon’ ‘-X’ ‘fdescfs’ ‘-X’ ‘overlay’ ‘-X’ ‘nsfs’ ‘-X’ ‘squashfs’ ‘-m’

grafik

Also it doesn’t cut the output anywhere in the string, it shows exact the first 4 partitions… so im really confused where to look next.

For my command ein only defined -R to be “/” and added
vars.disk_ignore_ereg_path = [ "^/boot/efi" ] what ist defined as datafield:
grafik

(Aflatto) #8

I tried to reproduce this on my setup and was unable to.

I’d recommend opening an issue in the https://community.icinga.com/c/community/

where the Icinga team actually answers and helps.

Sorry i could not help more.

#9

Thank you very much for trying to help me!

I will open an issue.