Apply hostgroups in director didn't work

Hello everybody.

I have the following strange behavior:
I define a host group in the Director and fill it with apply (host.name = * XY *). The “Choices” preview displays hosts matching the selection.
After successfully deploying, no hostgroups are displayed in icingaweb2.

My system data:
Icinga2 2.11.0-1
Icingaweb2 2.7.1
Director 1.5.0

Thanks for your support!

greetings
josh

I don’t get what you mean by that.
Can you show some screenshots?

Did you specify the host name of the object exactly as the object is named? Case sensitive, whitespace etc all matters!

Hello log1c.
Thanks for your reply.

Sorry, Screenshots are not possible for security reasons :smirk:

I’ve mistyped. I meant “Members” instead of “Choices”
When I fill the group with the rule, it previews all the hosts under Members that match the selection.
After deployment, the group is not displayed even though the members are present in the preview.
The search string is * XY * (asterisk before and after).

Blockquote
zones.d/director-global/hostgroups.conf
object HostGroup “Server” {
display_name = “Server”
assign where match(“XY”, host.name)
}

Greetings
Josh

Do you specify your search string with spaces after/before the asterisk?

Can you maybe try a more up-to-date version of the Icinga Director? Be aware the the most recent version needs some extra modules to be installed:

Yes, I can do that, but it will take some time (not today), because the server does not have internet access. I have to manually copy the files to the server after they have been checked by the AV scanner.

Thx for your support
josh

Small feedback:
With the director 1.6.0 no change.
I can not test 1.7.0 at the moment, because I do not know how to integrate the required service without systemd.

thx
josh

Do you understand that “host.name” in the notification rule is not the same as the display name of that host? We’ve had so many problems in rules with differences here, that we have decided to make sure that all host names and display names of hosts are exactly identical for each host…

1 Like

Hello Kai.
Thanks for the hint. But this is about the rule that works. (The “Members” preview displays hosts matching the selection.) In Icingaweb2, however, no host group is displayed.

EDIT:
Unfortunately, manually defined host groups (conf.d / groups.conf -groups.conf is included in icinga2.conf) are not displayed, although the groups.conf are also read out when deploying with the Icinga Director. The problem is more fundamental.

Hello everybody.
I can say after some tests that it is probably a problem of icingaweb2. Because the groups are available and work as intended. Because in Nagvis the groups are displayed and functional.

Hi.
The problem seems to be solved.
After a major upgrade of the versions to
icinga2: r2.11.2-1
icingaweb2: 2.7.3
director: 1.6.2
the host groups can also be seen in icingaweb2.
(By the way, the services were not visible, as I have stated).

Unfortunately, it took a while because I have no internet access at the customer, so I had to set up an offline apt-mirror on a USB disk. This content first had to be scanned for viruses and released before I could use it.

Unfortunately, the official Ubuntu Mirror has generated some virus alerts, so I had to try several mirrors (Netcologne has worked in the end). All this took a few weeks because the customer’s workflows take a few days.

Thanks and Greetings
Hobin